Bug 859907 - QEMU 1.1.x 1.2.x turns external monitor off when in fullscreen
QEMU 1.1.x 1.2.x turns external monitor off when in fullscreen
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: SDL (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Pisar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-24 07:42 EDT by Ali Akcaagac
Modified: 2013-01-23 11:11 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-23 11:11:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ali Akcaagac 2012-09-24 07:42:03 EDT
Hello

Runnin F17 here with latest updates.

I have a notebook with an external monitor applied to it. I need the external monitor for stock trading and watching charts. I also use qemu on the machine to run windows XP from a different partition.

Whenever I turn QEMU in fullscreen, QEMU turns the external monitor off. Turning QEMU off of fulscreen keeps the monitor still turned off. This is not acceptable because the external monitor still runs some serious business which run under Linux while QEMU only runs some stuff in an emulation. It should go fullscreen but needs to coexists with what is running elsewhere. Another misbehavior is that QEMU only allows going fullscreen on the internal monitor but not where the window has popped up. eg. if I open QEMU and move it to the external monitor and have it go fullscreen then I expect the fullscreen to appear on the external monitor and not switching back to internal and turning external off.

Maybe this can be fixed somehow ?
Comment 1 Petr Pisar 2012-10-01 10:42:18 EDT
There is an excellent report <http://lists.libsdl.org/pipermail/sdl-libsdl.org/2012-September/085922.html> about full screen support on SDL mailing list. (It describes SDL-2, but it applies to SDL-1.2 mostly too.)

There were some changes in SDL 1.2.15 (since Fedora 18) in full screen mode settings. You can check whether it works better for you. However I cannot back-port it as it changes default behavior which would affect other people satisfied with current status.

If 1.2.15 fixed the problem for you I could try to port it with restored original behavior and you could override full screen settings by an environment variable.
Comment 2 Petr Pisar 2013-01-23 11:11:02 EST
1.2.15 does not use XRANDR by default, when going to fullscreen, it sets dual head into cloning. It does not turn off other secondary output, but it displays the same image.

If requesting XRANDR with SDL_VIDEO_X11_XRANDR=1 environment variable, the secondary monitor will get off. (At least in my case because the secondary one has lower resolution.)

Note You need to log in before you can comment on or make changes to this bug.