Bug 859912 - [abrt] htop-1.0.1-1.fc17: CRT_handleSIGSEGV: Process /usr/bin/htop was killed by signal 6 (SIGABRT)
Summary: [abrt] htop-1.0.1-1.fc17: CRT_handleSIGSEGV: Process /usr/bin/htop was killed...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: htop
Version: 17
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Milos Jakubicek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:d87aa928b5925fdc3f53a9786d3...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-09-24 11:44 UTC by Torste Aikio
Modified: 2013-01-12 00:25 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-12-13 05:53:59 UTC


Attachments (Terms of Use)
File: core_backtrace (348 bytes, text/plain)
2012-09-24 11:44 UTC, Torste Aikio
no flags Details
File: environ (3.29 KB, text/plain)
2012-09-24 11:44 UTC, Torste Aikio
no flags Details
File: backtrace (5.45 KB, text/plain)
2012-09-24 11:44 UTC, Torste Aikio
no flags Details
File: limits (1.29 KB, text/plain)
2012-09-24 11:44 UTC, Torste Aikio
no flags Details
File: cgroup (129 bytes, text/plain)
2012-09-24 11:44 UTC, Torste Aikio
no flags Details
File: maps (2.83 KB, text/plain)
2012-09-24 11:44 UTC, Torste Aikio
no flags Details
File: dso_list (1.04 KB, text/plain)
2012-09-24 11:44 UTC, Torste Aikio
no flags Details
File: var_log_messages (143 bytes, text/plain)
2012-09-24 11:44 UTC, Torste Aikio
no flags Details
File: open_fds (90 bytes, text/plain)
2012-09-24 11:44 UTC, Torste Aikio
no flags Details

Description Torste Aikio 2012-09-24 11:44:05 UTC
Description of problem:
1. Filtered the view so that a single process is visible

2. Closed the application that was visible

Could not reproduce.


Version-Release number of selected component:
htop-1.0.1-1.fc17

Additional info:
libreport version: 2.0.13
abrt_version:   2.0.12
backtrace_rating: 4
cmdline:        htop
crash_function: CRT_handleSIGSEGV
kernel:         3.5.2-3.fc17.i686

truncated backtrace:
:Thread no. 1 (1 frames)
: #3 CRT_handleSIGSEGV at CRT.c

Comment 1 Torste Aikio 2012-09-24 11:44:09 UTC
Created attachment 616496 [details]
File: core_backtrace

Comment 2 Torste Aikio 2012-09-24 11:44:11 UTC
Created attachment 616497 [details]
File: environ

Comment 3 Torste Aikio 2012-09-24 11:44:13 UTC
Created attachment 616498 [details]
File: backtrace

Comment 4 Torste Aikio 2012-09-24 11:44:15 UTC
Created attachment 616499 [details]
File: limits

Comment 5 Torste Aikio 2012-09-24 11:44:18 UTC
Created attachment 616500 [details]
File: cgroup

Comment 6 Torste Aikio 2012-09-24 11:44:20 UTC
Created attachment 616501 [details]
File: maps

Comment 7 Torste Aikio 2012-09-24 11:44:22 UTC
Created attachment 616502 [details]
File: dso_list

Comment 8 Torste Aikio 2012-09-24 11:44:24 UTC
Created attachment 616503 [details]
File: var_log_messages

Comment 9 Torste Aikio 2012-09-24 11:44:29 UTC
Created attachment 616504 [details]
File: open_fds

Comment 10 Dmitry Komarov 2012-11-15 20:12:58 UTC
The application was launched in XTerm terminal emulator and was working for some time while window was not in focus. Then I switched focus from other app back to the XTerm and the htop crashed.

backtrace_rating: 4
Package: htop-1.0.1-1.fc17
Architecture: x86_64
OS Release: Fedora release 17 (Beefy Miracle)

Comment 11 Fedora Update System 2012-12-04 12:36:45 UTC
htop-1.0.2-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/htop-1.0.2-1.fc18

Comment 12 Fedora Update System 2012-12-04 12:40:11 UTC
htop-1.0.2-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/htop-1.0.2-1.fc17

Comment 13 Fedora Update System 2012-12-04 12:41:56 UTC
htop-1.0.2-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/htop-1.0.2-1.fc16

Comment 14 Fedora Update System 2012-12-04 21:13:01 UTC
Package htop-1.0.2-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing htop-1.0.2-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-19663/htop-1.0.2-1.fc18
then log in and leave karma (feedback).

Comment 15 Fedora Update System 2012-12-13 05:54:00 UTC
htop-1.0.2-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2012-12-13 05:55:14 UTC
htop-1.0.2-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2013-01-12 00:25:26 UTC
htop-1.0.2-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.