Bug 859928 - [abrt] system-config-kickstart-2.8.10-2.fc18: packages.py:35:<module>:ImportError: No module named iw
[abrt] system-config-kickstart-2.8.10-2.fc18: packages.py:35:<module>:ImportE...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-kickstart (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
abrt_hash:86f74694f93397cd43901bd4c72...
:
: 896173 901738 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-24 08:12 EDT by Jan Sedlák
Modified: 2013-02-08 12:27 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-07 21:26:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (7.62 KB, text/plain)
2012-09-24 08:12 EDT, Jan Sedlák
no flags Details
File: core_backtrace (302 bytes, text/plain)
2012-09-24 08:12 EDT, Jan Sedlák
no flags Details

  None (edit)
Description Jan Sedlák 2012-09-24 08:12:42 EDT
Description of problem:
Installed and started "system-config-kickstart".

Version-Release number of selected component:
system-config-kickstart-2.8.10-2.fc18

Additional info:
libreport version: 2.0.13
abrt_version:   2.0.12
cmdline:        /usr/bin/python2 /usr/bin/system-config-kickstart
kernel:         3.6.0-0.rc6.git0.2.fc18.x86_64
Comment 1 Jan Sedlák 2012-09-24 08:12:45 EDT
Created attachment 616530 [details]
File: backtrace
Comment 2 Jan Sedlák 2012-09-24 08:12:47 EDT
Created attachment 616531 [details]
File: core_backtrace
Comment 3 Daniel Belton 2012-10-07 11:04:45 EDT
run system-config-kickstart

Package: system-config-kickstart-2.8.10-2.fc18
OS Release: Fedora release 18 (Spherical Cow)
Comment 4 Gene Czarcinski 2012-12-09 12:47:27 EST
I have no idea what comment 3 is suppose to mean.

As of today and F18-beta, it is still broken.

Given the date of this report, either nobody is using this or nobody cares if it works.
Comment 5 Chris Lumens 2012-12-10 10:42:03 EST
Too busy working on anaconda, which cannot be updated post-release.  I'll get to this for F19.  Sorry.
Comment 6 Chris Lumens 2013-01-16 14:24:23 EST
*** Bug 896173 has been marked as a duplicate of this bug. ***
Comment 7 Chris Lumens 2013-01-20 10:41:14 EST
*** Bug 901738 has been marked as a duplicate of this bug. ***
Comment 8 James Shelby 2013-01-21 12:30:52 EST
/usr/lib64/python2.7/site-packages/pyanaconda/iw does not appear to exist with Fedora 18 anaconda
Comment 9 Edwind Richzendy Contreras Soto 2013-01-26 12:57:06 EST
What about this?

this problem still it's  in Version 2.8.10 to F18
Comment 10 Fedora Update System 2013-02-01 11:57:55 EST
system-config-kickstart-2.9.0-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/system-config-kickstart-2.9.0-1.fc18
Comment 11 Gene Czarcinski 2013-02-01 13:00:44 EST
verified: works
Comment 12 Edwind Richzendy Contreras Soto 2013-02-01 13:31:29 EST
Verified: Works

Thanks a lot!
Comment 13 Fedora Update System 2013-02-01 23:28:53 EST
Package system-config-kickstart-2.9.0-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing system-config-kickstart-2.9.0-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-1856/system-config-kickstart-2.9.0-1.fc18
then log in and leave karma (feedback).
Comment 14 Fedora Update System 2013-02-07 21:27:01 EST
system-config-kickstart-2.9.0-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 John Faichney 2013-02-08 01:14:32 EST
I reported problems with the kickstart file generated by anaconda - see https://bugzilla.redhat.com/show_bug.cgi?id=908914 - but would consider system-config-kickstart as a workaround.

But when I follow the directions given in comments #13 and #14, above, I am offered nothing newer than version 2.8.10-2.fc18.  But (as reported above - see comment #9), version 2.8.10-2 does not work (because of the missing iw package.)

However, if I follow the links on either of the admin page referenced above (comments #10 and #13), I see that the version in-question is available at http://kojipkgs.fedoraproject.org//packages/system-config-kickstart/2.9.0/1.fc18/noarch/system-config-kickstart-2.9.0-1.fc18.noarch.rpm - is this what "pushed to the Fedora 18 stable repository" means?  What yum invocation do I need to address this repository?  Thanks.
Comment 16 John Faichney 2013-02-08 01:17:11 EST
I reported problems with the kickstart file generated by anaconda - see https://bugzilla.redhat.com/show_bug.cgi?id=908914 - but would consider system-config-kickstart as a workaround.

But when I follow the directions given in comments #13 and #14, above, I am offered nothing newer than version 2.8.10-2.fc18.  But (as reported above - see comment #9), version 2.8.10-2 does not work (because of the missing iw package.)

However, if I follow the links on either of the admin pages referenced above (comments #10 and #13), I see that the version in-question is available at http://kojipkgs.fedoraproject.org//packages/system-config-kickstart/2.9.0/1.fc18/noarch/system-config-kickstart-2.9.0-1.fc18.noarch.rpm - is this what "pushed to the Fedora 18 stable repository" means?  What yum invocation do I need to address this repository?  Thanks.
Comment 17 John Faichney 2013-02-08 12:04:43 EST
I see that system-config-kickstart is now available; perhaps propagation took longer than expected.

I appreciate that busy people took time from other and possibly more-critical tasks to bring this utility back to life.  That said, it's difficult to feel confident that system-config-kickstart is fc18-aware; for example, it provides no hooks for configuring LVM or BTRFS, nor even for device encryption.  Particularly as these parameterisations are difficult to debug (and because debugging kickstart files involves particularly painful latencies), this is unfortunate.

I hope that this project, or some variant, can be resurrected in the near future.  FWIW, it has often struck me as strange that anaconda itself does not actually =use= its own kickstart file - that is, treat its GUI as directed only to generating 'correct' kickstart files, which are then passed to an interpreter.  In this scenario, system-config-kickstart =is= the anaconda GUI, and vice-versa; further, the GUI is =just= a user-space application (and, so, able to be run at any time, post-OS installation.)

This sort of paradigm is well-established in other domains, and its benefits w/rt determinacy and transparency are, I think, well-understood; further, it's not apparent that anaconda's tight GUI::installation binding enables functionality unobtainable by other means.  The current design, OTOH, seems to guarantee that system-config-kickstart will fall into neglect - which, we may expect, will discourage end-users from taking advantage of it.
Comment 18 Chris Lumens 2013-02-08 12:27:10 EST
> I appreciate that busy people took time from other and possibly
> more-critical tasks to bring this utility back to life.  That said, it's
> difficult to feel confident that system-config-kickstart is fc18-aware; for
> example, it provides no hooks for configuring LVM or BTRFS, nor even for
> device encryption.  Particularly as these parameterisations are difficult to
> debug (and because debugging kickstart files involves particularly painful
> latencies), this is unfortunate.

It has never supported configuration of LVM, or btrfs, or lots and lots of other things.

> I hope that this project, or some variant, can be resurrected in the near
> future.  FWIW, it has often struck me as strange that anaconda itself does
> not actually =use= its own kickstart file - that is, treat its GUI as
> directed only to generating 'correct' kickstart files, which are then passed
> to an interpreter.  In this scenario, system-config-kickstart =is= the
> anaconda GUI, and vice-versa; further, the GUI is =just= a user-space
> application (and, so, able to be run at any time, post-OS installation.)

If you've been following the new UI in anaconda, you'd see this is basically what we've set up now.  anaconda does generate a kickstart file internally (though, the partitioning section of it does still need some work).  The eventual plan is to just use the anaconda UI as a kickstart generator, perhaps with some extra s-c-ks specific spokes for things like specifying your drives and doing authconfig.

What I've done for now is just a stop-gap to make it work in some capacity while we continue work in anaconda to support the new plan.  However that is going to take some time, and this is pretty far off topic for this bug report.

Note You need to log in before you can comment on or make changes to this bug.