Bug 859932 - Do not mix bits and bytes
Do not mix bits and bytes
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-24 08:27 EDT by Jan Stodola
Modified: 2012-10-23 05:10 EDT (History)
4 users (show)

See Also:
Fixed In Version: anaconda-18.17-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-23 05:10:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
graphical install screen 1 (92.85 KB, image/png)
2012-09-24 08:29 EDT, Jan Stodola
no flags Details
graphical install screen 2 (139.50 KB, image/png)
2012-09-24 08:29 EDT, Jan Stodola
no flags Details
graphical install screen 3 (104.06 KB, image/png)
2012-10-15 08:32 EDT, Jan Stodola
no flags Details

  None (edit)
Description Jan Stodola 2012-09-24 08:27:58 EDT
Description of problem:
On some screens, anaconda uses bits instead of bytes for storage sizes. It is visible during both graphical and text-mode installs.
Screen from text-mode install:

Install Destination

[x] 1) dasda

[x] 2) dasdb

[x] 3) dasdc

3 disks selected; 7.04 Gb capacity; 2.69 Gb free ...

  Please make your choice from above ['q' to quit | 'c' to continue]:



Version-Release number of selected component (if applicable):
anaconda 18.8

How reproducible:
always

Steps to Reproduce:
1. start graphical or text-mode installation
2. go through partitioning, check if all storage sizes use correct units
  
Actual results:
bits instead of bytes on some places

Expected results:
sizes with correct units

Additional info:
1 B == 8 b
Comment 1 Jan Stodola 2012-09-24 08:29:11 EDT
Created attachment 616543 [details]
graphical install screen 1
Comment 2 Jan Stodola 2012-09-24 08:29:30 EDT
Created attachment 616544 [details]
graphical install screen 2
Comment 3 Chris Lumens 2012-10-10 22:24:24 EDT
Looks like a fast and furious fix.
Comment 4 Fedora Update System 2012-10-11 21:06:01 EDT
anaconda-18.16-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.16-1.fc18
Comment 5 Fedora Update System 2012-10-12 13:55:24 EDT
Package anaconda-18.16-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.16-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16018/anaconda-18.16-1.fc18
then log in and leave karma (feedback).
Comment 6 Jan Stodola 2012-10-15 08:32:32 EDT
Created attachment 627394 [details]
graphical install screen 3

There is one more case that needs to be fixed. When all disk space is used, anaconda reports:

AVAILABLE SPACE
0 b

Tested with anaconda 18.16, screenshot attached. Moving back to ASSIGNED
Comment 7 Chris Lumens 2012-10-15 10:27:25 EDT
Okay, think I see it.
Comment 8 Fedora Update System 2012-10-16 23:07:33 EDT
anaconda-18.17-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.17-1.fc18
Comment 9 Fedora Update System 2012-10-17 13:28:36 EDT
Package anaconda-18.17-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.17-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16295/anaconda-18.17-1.fc18
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2012-10-17 22:36:32 EDT
anaconda-18.18-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.18-1.fc18
Comment 11 Fedora Update System 2012-10-19 21:32:22 EDT
anaconda-18.19-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.19-1.fc18
Comment 12 Jan Stodola 2012-10-23 05:10:32 EDT
All reported issues are fixed, verified with anaconda-18.19-1.fc18.

Thanks, closing this bug.

Note You need to log in before you can comment on or make changes to this bug.