Bug 859934 - HP ProLiant Kernel trace: wait_for_completion
HP ProLiant Kernel trace: wait_for_completion
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.8
i686 Linux
unspecified Severity high
: rc
: ---
Assigned To: Red Hat Kernel Manager
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-24 08:32 EDT by fufme
Modified: 2014-09-03 14:09 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:02:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description fufme 2012-09-24 08:32:29 EDT
On one of our servers with RHEL 5.8 (updated to lastest using "yum update") I got these messages:

Sep 24 13:50:34 server kernel: INFO: task cmaeventd:5006 blocked for more than 120 seconds.
Sep 24 13:50:34 server kernel: "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
Sep 24 13:50:34 server kernel: cmaeventd     D 00000067  2416  5006      1          5018  4943 (NOTLB)
Sep 24 13:50:34 server kernel:        e9593d18 00003082 0a625e4b 00000067 fffb4000 00000003 c06a1300 00000007
Sep 24 13:50:34 server kernel:        e9bd0550 0a642c69 00000067 0001ce1e 00000001 e9bd065c c2819544 e9072040
Sep 24 13:50:34 server kernel:        000280d2 00000000 00000000 00000030 00000030 00000000 e3bb0260 ffffffff
Sep 24 13:50:34 server kernel: Call Trace:
Sep 24 13:50:34 server kernel:  [<c062400d>] wait_for_completion+0x6b/0x8f
Sep 24 13:50:34 server kernel:  [<c041f867>] default_wake_function+0x0/0xc
Sep 24 13:50:34 server kernel:  [<f892752d>] cciss_ioctl+0x5e5/0xaa5 [cciss]
Sep 24 13:50:34 server kernel:  [<c041f85d>] try_to_wake_up+0x3e8/0x3f2
Sep 24 13:50:34 server kernel:  [<c04e75b3>] blkdev_driver_ioctl+0x4b/0x5b
Sep 24 13:50:34 server kernel:  [<c04e7cce>] blkdev_ioctl+0x70b/0x759
Sep 24 13:50:34 server kernel:  [<c054420b>] n_tty_receive_buf+0xc9f/0xcad
Sep 24 13:50:34 server kernel:  [<c048dce6>] dput+0x22/0xed
Sep 24 13:50:34 server kernel:  [<c054420b>] n_tty_receive_buf+0xc9f/0xcad
Sep 24 13:50:34 server kernel:  [<c048d0bd>] d_rehash+0x1c/0x2b
Sep 24 13:50:34 server kernel:  [<c0491944>] mntput_no_expire+0x11/0x6a
Sep 24 13:50:34 server kernel:  [<c04f1626>] kobject_get+0xf/0x13
Sep 24 13:50:34 server kernel:  [<c04e8211>] get_disk+0x35/0x6e
Sep 24 13:50:34 server kernel:  [<c04e8251>] exact_lock+0x7/0xd
Sep 24 13:50:34 server kernel:  [<c0565059>] kobj_lookup+0x10d/0x168
Sep 24 13:50:34 server kernel:  [<c04e7d1c>] exact_match+0x0/0x4
Sep 24 13:50:34 server kernel:  [<c06247f2>] mutex_lock+0xb/0x19
Sep 24 13:50:34 server kernel:  [<c047f54d>] do_open+0x213/0x2ce
Sep 24 13:50:34 server kernel:  [<c047f774>] blkdev_open+0x0/0x44
Sep 24 13:50:34 server kernel:  [<c047f790>] blkdev_open+0x1c/0x44
Sep 24 13:50:34 server kernel:  [<c0476844>] __dentry_open+0xea/0x1ab
Sep 24 13:50:34 server kernel:  [<c054420b>] n_tty_receive_buf+0xc9f/0xcad
Sep 24 13:50:34 server kernel:  [<c047ec92>] block_ioctl+0x13/0x16
Sep 24 13:50:34 server kernel:  [<c047ec7f>] block_ioctl+0x0/0x16
Sep 24 13:50:34 server kernel:  [<c0488819>] do_ioctl+0x1c/0x5d
Sep 24 13:50:34 server kernel:  [<c0488dad>] vfs_ioctl+0x47b/0x4d3
Sep 24 13:50:34 server kernel:  [<c044d453>] audit_syscall_entry+0x193/0x1bd
Sep 24 13:50:34 server kernel:  [<c0488e4d>] sys_ioctl+0x48/0x5f
Sep 24 13:50:34 server kernel:  [<c0404f4b>] syscall_call+0x7/0xb
Sep 24 13:50:34 server kernel:  [<c054420b>] n_tty_receive_buf+0xc9f/0xcad
Sep 24 13:50:34 server kernel:  =======================

kernel is vmlinuz-2.6.18-308.8.1.el5. When this happens, any access to disk is blocked, processes are in "D" state (we are serving there mainly samba shares) and only reboot does help.

Hardware is HP ProLiant ML370 G5. According to HP support I updated it with "HP SmartUpdate DVD 10.10" (DVD with firware updates).

Is it kernel issue?
Comment 1 RHEL Product and Program Management 2014-03-07 08:33:20 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 2 RHEL Product and Program Management 2014-06-02 09:02:07 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.