Bug 859943 - kernel-tools package contains both binaries and libs
kernel-tools package contains both binaries and libs
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-24 08:56 EDT by John Sullivan
Modified: 2012-11-28 09:12 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-28 09:12:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sullivan 2012-09-24 08:56:34 EDT
kernel-tools.x86_64 contains a whole bunch of binaries, some perl modules, and man pages. This is fine.

It also contains /usr/lib64/libcpupower.so.0.0.0.

To build a 32-bit binary which links with libcpupower you also need kernel-tools.i686 and kernel-tools-devel.i686 to pull in /usr/lib/libcpupower.so*. But those clash on all the other files so yum won't let you install them. You can rpm --force them in of course, but that then causes yum update to fail whenever the kernel packages get bumped (as well as probably leaving you with the i686 binaries which you'd probably rather keep as the x86_64 versions).

kernel-tools needs to be split out into kernel-tools and kernel-tools-libs{,-devel}.
Comment 1 Josh Boyer 2012-09-28 08:44:26 EDT
Fixed in Fedora git on all branches as suggested.  F18 is currently building.  The other branches will get updates for this as they are built.
Comment 2 Fedora Update System 2012-10-02 21:36:59 EDT
kernel-3.5.5-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/kernel-3.5.5-1.fc17
Comment 3 Fedora Update System 2012-10-03 19:56:20 EDT
Package kernel-3.5.5-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.5.5-1.fc17'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15323/kernel-3.5.5-1.fc17
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2012-10-08 07:45:21 EDT
kernel-3.5.6-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/kernel-3.5.6-1.fc17
Comment 5 John Sullivan 2012-10-08 08:31:28 EDT
Running the above command on fc16 to get kernel-3.4.12-1.fc16, failed with the error:

--> Running transaction check
---> Package kernel.x86_64 0:3.4.12-1.fc16 will be installed
---> Package kernel-debuginfo.x86_64 0:3.4.11-1.fc16 will be updated
---> Package kernel-debuginfo.x86_64 0:3.4.12-1.fc16 will be an update
---> Package kernel-debuginfo-common-x86_64.x86_64 0:3.4.11-1.fc16 will be updated
---> Package kernel-debuginfo-common-x86_64.x86_64 0:3.4.12-1.fc16 will be an update
---> Package kernel-devel.x86_64 0:3.4.12-1.fc16 will be installed
---> Package kernel-doc.noarch 0:3.4.11-1.fc16 will be updated
---> Package kernel-doc.noarch 0:3.4.12-1.fc16 will be an update
---> Package kernel-headers.x86_64 0:3.4.11-1.fc16 will be updated
---> Package kernel-headers.x86_64 0:3.4.12-1.fc16 will be an update
---> Package kernel-tools.x86_64 0:3.4.11-1.fc16 will be updated
--> Processing Dependency: libcpupower.so.0()(64bit) for package: kernel-tools-devel-3.4.11-1.fc16.x86_64
--> Processing Dependency: libcpupower.so.0()(64bit) for package: kernel-tools-3.4.12-1.fc16.x86_64
--> Processing Dependency: libcpupower.so.0()(64bit) for package: 1:gnome-applets-2.32.0-3.fc16.x86_64
--> Processing Dependency: kernel-tools = 3.4.11-1.fc16 for package: kernel-tools-devel-3.4.11-1.fc16.x86_64
---> Package kernel-tools.x86_64 0:3.4.12-1.fc16 will be an update
--> Running transaction check
---> Package kernel-tools.i686 0:3.4.11-1.fc16 will be installed
---> Package kernel-tools.x86_64 0:3.4.11-1.fc16 will be updated
---> Package kernel-tools-libs.x86_64 0:3.4.12-1.fc16 will be installed
--> Finished Dependency Resolution
Error: Protected multilib versions: kernel-tools-3.4.11-1.fc16.i686 != kernel-tools-3.4.12-1.fc16.x86_64

The following kernel-* packages were already installed:

Mon 24 Sep 2012 13:27:38 BST  	kernel-3.4.11-1.fc16.x86_64
Tue 04 Sep 2012 21:06:02 BST  	kernel-devel-3.4.9-2.fc16.x86_64
Mon 24 Sep 2012 13:26:45 BST  	kernel-debuginfo-3.4.11-1.fc16.x86_64
Mon 24 Sep 2012 13:27:05 BST  	kernel-doc-3.4.11-1.fc16.noarch
Mon 24 Sep 2012 13:26:52 BST  	kernel-headers-3.4.11-1.fc16.x86_64
Mon 24 Sep 2012 13:27:16 BST  	kernel-devel-3.4.11-1.fc16.x86_64
Mon 24 Sep 2012 13:25:29 BST  	kernel-debuginfo-common-x86_64-3.4.11-1.fc16.x86_64
Wed 05 Sep 2012 11:23:27 BST  	kernel-3.4.9-2.fc16.x86_64
Mon 24 Sep 2012 13:25:32 BST  	kernel-tools-3.4.11-1.fc16.x86_64
Mon 24 Sep 2012 13:25:33 BST  	kernel-tools-devel-3.4.11-1.fc16.x86_64

Removing kernel-tools-* with "rpm -e --nodeps", then repeating the yum update, then re-installing the new kernel-tools-* packages (in both x86_64 and i686 versions) seems to have worked.
Comment 6 Dave Jones 2012-10-23 11:41:54 EDT
# Mass update to all open bugs.

Kernel 3.6.2-1.fc16 has just been pushed to updates.
This update is a significant rebase from the previous version.

Please retest with this kernel, and let us know if your problem has been fixed.

In the event that you have upgraded to a newer release and the bug you reported
is still present, please change the version field to the newest release you have
encountered the issue with.  Before doing so, please ensure you are testing the
latest kernel update in that release and attach any new and relevant information
you may have gathered.

If you are not the original bug reporter and you still experience this bug,
please file a new report, as it is possible that you may be seeing a
different problem. 
(Please don't clone this bug, a fresh bug referencing this bug in the comment is sufficient).
Comment 7 John Sullivan 2012-10-23 20:08:19 EDT
I tried to update on a second fc16 machine which was still running 3.4.11.

Attempting to directly update or install 3.6.2-1.fc16 fails with the same error as above:

# yum update
Loaded plugins: auto-update-debuginfo, langpacks, presto, refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package kernel.x86_64 0:3.6.2-1.fc16 will be installed
---> Package kernel-devel.x86_64 0:3.6.2-1.fc16 will be installed
---> Package kernel-headers.x86_64 0:3.4.11-1.fc16 will be updated
---> Package kernel-headers.x86_64 0:3.6.2-1.fc16 will be an update
---> Package kernel-tools.x86_64 0:3.4.11-1.fc16 will be updated
--> Processing Dependency: libcpupower.so.0()(64bit) for package: kernel-tools-3.6.2-1.fc16.x86_64
--> Processing Dependency: libcpupower.so.0()(64bit) for package: 1:gnome-applets-2.32.0-3.fc16.x86_64
--> Processing Dependency: libcpupower.so.0()(64bit) for package: kernel-tools-devel-3.4.11-1.fc16.x86_64
--> Processing Dependency: kernel-tools = 3.4.11-1.fc16 for package: kernel-tools-devel-3.4.11-1.fc16.x86_64
---> Package kernel-tools.x86_64 0:3.6.2-1.fc16 will be an update
--> Running transaction check
---> Package kernel-tools.x86_64 0:3.4.11-1.fc16 will be updated
--> Processing Dependency: kernel-tools = 3.4.11-1.fc16 for package: kernel-tools-devel-3.4.11-1.fc16.x86_64
---> Package kernel-tools-libs.x86_64 0:3.6.2-1.fc16 will be installed
--> Finished Dependency Resolution
Error: Package: kernel-tools-devel-3.4.11-1.fc16.x86_64 (@updates)
           Requires: kernel-tools = 3.4.11-1.fc16
           Removing: kernel-tools-3.4.11-1.fc16.x86_64 (@updates)
               kernel-tools = 3.4.11-1.fc16
           Updated By: kernel-tools-3.6.2-1.fc16.x86_64 (updates)
               kernel-tools = 3.6.2-1.fc16
           Available: kernel-tools-3.1.0-7.fc16.i686 (fedora)
               kernel-tools = 3.1.0-7.fc16
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
# yum install kernel{,-devel,-tools,-tools-libs,-tools-libs-devel,-headers}
Loaded plugins: auto-update-debuginfo, langpacks, presto, refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package kernel.x86_64 0:3.6.2-1.fc16 will be installed
---> Package kernel-devel.x86_64 0:3.6.2-1.fc16 will be installed
---> Package kernel-headers.x86_64 0:3.4.11-1.fc16 will be updated
---> Package kernel-headers.x86_64 0:3.6.2-1.fc16 will be an update
---> Package kernel-tools.x86_64 0:3.4.11-1.fc16 will be updated
--> Processing Dependency: kernel-tools = 3.4.11-1.fc16 for package: kernel-tools-devel-3.4.11-1.fc16.x86_64
---> Package kernel-tools.x86_64 0:3.6.2-1.fc16 will be an update
---> Package kernel-tools-libs.x86_64 0:3.6.2-1.fc16 will be installed
---> Package kernel-tools-libs-devel.x86_64 0:3.6.2-1.fc16 will be installed
--> Finished Dependency Resolution
Error: Package: kernel-tools-devel-3.4.11-1.fc16.x86_64 (@updates)
           Requires: kernel-tools = 3.4.11-1.fc16
           Removing: kernel-tools-3.4.11-1.fc16.x86_64 (@updates)
               kernel-tools = 3.4.11-1.fc16
           Updated By: kernel-tools-3.6.2-1.fc16.x86_64 (updates)
               kernel-tools = 3.6.2-1.fc16
           Available: kernel-tools-3.1.0-7.fc16.i686 (fedora)
               kernel-tools = 3.1.0-7.fc16
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


I could force the update in the same way as in comment 5, however I will leave it running the previous version for now in case a cleaner upgrade path becomes available to test.
Comment 8 Michael Ben-Gershon 2012-11-17 17:26:25 EST
# yum -y update
Loaded plugins: fastestmirror, langpacks, presto, refresh-packagekit
Loading mirror speeds from cached hostfile
 * fedora: mirror.ox.ac.uk
 * updates: mirror.ox.ac.uk
Resolving Dependencies
--> Running transaction check
---> Package kernel-tools.x86_64 0:3.4.11-1.fc16 will be updated
--> Processing Dependency: libcpupower.so.0()(64bit) for package: kernel-tools-3.6.6-1.fc16.x86_64
--> Processing Dependency: libcpupower.so.0()(64bit) for package: kernel-tools-devel-3.4.11-1.fc16.x86_64
--> Processing Dependency: kernel-tools = 3.4.11-1.fc16 for package: kernel-tools-devel-3.4.11-1.fc16.x86_64
---> Package kernel-tools.x86_64 0:3.6.6-1.fc16 will be an update
--> Running transaction check
---> Package kernel-tools.x86_64 0:3.4.11-1.fc16 will be updated
--> Processing Dependency: kernel-tools = 3.4.11-1.fc16 for package: kernel-tools-devel-3.4.11-1.fc16.x86_64
---> Package kernel-tools-libs.x86_64 0:3.6.6-1.fc16 will be installed
--> Finished Dependency Resolution
Error: Package: kernel-tools-devel-3.4.11-1.fc16.x86_64 (@updates)
           Requires: kernel-tools = 3.4.11-1.fc16
           Removing: kernel-tools-3.4.11-1.fc16.x86_64 (@updates)
               kernel-tools = 3.4.11-1.fc16
           Updated By: kernel-tools-3.6.6-1.fc16.x86_64 (updates)
               kernel-tools = 3.6.6-1.fc16
           Available: kernel-tools-3.1.0-7.fc16.i686 (fedora)
               kernel-tools = 3.1.0-7.fc16
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

So the problem is still here, with 3.6.6-1 !

Note You need to log in before you can comment on or make changes to this bug.