Bug 859954 - Restart button is able to be clicked, but does not do anything for some providers
Restart button is able to be clicked, but does not do anything for some provi...
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.1.0
Unspecified Unspecified
unspecified Severity high
: beta4
: ---
Assigned To: Shveta
Rehana
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-24 09:25 EDT by james labocki
Modified: 2012-12-04 10:21 EST (History)
8 users (show)

See Also:
Fixed In Version: aeolus-conductor-0.13.18-1.el6cf
Doc Type: Bug Fix
Doc Text:
The restart button was displayed even when restarting the instance was not a supported action. For RHEV and vSphere instances, this meant the restart button was clickable, but no action occurred. This update removes the restart button if the action is not supported. RHEV instances no longer show the restart button, and vSphere instances display the button and restarts the instance if clicked.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 10:21:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rhev restart button (44.85 KB, image/png)
2012-10-16 15:23 EDT, Shveta
no flags Details
vsphere restart button (46.23 KB, image/png)
2012-10-16 15:24 EDT, Shveta
no flags Details

  None (edit)
Description james labocki 2012-09-24 09:25:55 EDT
Description of problem:
On providers that do not support restarting instances yet (RHEV, vSphere) the Restart button is able to be clicked, but does not do anything. This is confusing to the user.

To reproduce:
1. Launch two instances. One to RHEV provider and one to EC2 provider.

2. Wait until instances are running.

3. Select RHEV instance and select "restart".
  a. Nothing happens in the conductor UI.
  b. Nothing happens in the RHEV-M interface.

4. Select Amazon instance select "restart".
  a. Instance restarts in EC2


Expected results:
On of the following should be done:

1. check the provider when displaying instance information and remove the ability to press restart (hide it or grey it out) on providers that do not support restarting instances (RHEV, vSphere).

2. Make the restart button restart the instances on those providers.

I am expecting that #1 is the easier solution in the short term.
Comment 2 james labocki 2012-09-24 10:28:14 EDT
Bug for adding documentation

https://bugzilla.redhat.com/show_bug.cgi?id=859957
Comment 3 Matt Wagner 2012-10-04 14:18:53 EDT
On master and 1.1:

commit 99e964aad3270176beaec1ec0110da72038610be
Author: Tomáš Hrčka <thrcka@redhat.com>
Date:   Wed Oct 3 16:17:10 2012 +0200

    BZ859954 - Don't display buttons on instance card if actions are not supported
    
    https://bugzilla.redhat.com/show_bug.cgi?id=859954
    
    Signed-off-by: Matt Wagner <matt.wagner@redhat.com>
    (cherry picked from commit f95eb6569d4917cd4782b014f08c2dddb8b2a720)
Comment 4 Steve Linabery 2012-10-09 11:29:22 EDT
99e964a on 1.1
Comment 6 Shveta 2012-10-16 15:23:28 EDT
Created attachment 628339 [details]
rhev restart button

Restart button not displayed for RHEV instances.
Comment 7 Shveta 2012-10-16 15:24:28 EDT
Created attachment 628351 [details]
vsphere restart button

Restart button displayed for Vsphere and restarts instance if clicked.
Comment 9 errata-xmlrpc 2012-12-04 10:21:06 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.