Bug 859998 - Disable edit user fields when in LDAP mode
Disable edit user fields when in LDAP mode
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.1.0
All All
high Severity medium
: beta4
: ---
Assigned To: Tzu-Mainn Chen
Rehana
: Triaged
: 859511 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-24 11:10 EDT by Aaron Weitekamp
Modified: 2012-12-04 10:21 EST (History)
7 users (show)

See Also:
Fixed In Version: aeolus-conductor-0.13.18-1.el6cf
Doc Type: Bug Fix
Doc Text:
The edit user fields were active in LDAP mode Attempts to edit the user resulted in the creations of a local user, which was not supported. A check is now performed to see if Conductor is in LDAP mode and, if so, disables the edit user fields.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 10:21:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
edit_user_in_ldap_mode (46.42 KB, image/png)
2012-10-10 20:41 EDT, Shveta
no flags Details

  None (edit)
Description Aaron Weitekamp 2012-09-24 11:10:34 EDT
Description of problem:
LDAP mode is read-only, meaning updating the LDAP server from the CFCE client is not supported. Therefore the edit user fields should be disabled when in LDAP mode.

Related discussion: BZ-859511


Version-Release number of selected component (if applicable):
v1.1
[root@qeblade41 share]# rpm -qa |grep aeolus
aeolus-conductor-0.13.8-1.el6cf.noarch
aeolus-all-0.13.8-1.el6cf.noarch
aeolus-conductor-doc-0.13.8-1.el6cf.noarch
rubygem-aeolus-cli-0.7.1-1.el6cf.noarch
aeolus-conductor-daemons-0.13.8-1.el6cf.noarch
aeolus-configure-2.8.6-1.el6cf.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-configserver-0.4.10-2.el6cf.noarch


Steps to Reproduce:
1. config CFCE with LDAP server
2. nav to edit a user
3. note edit fields

Actual results: 
Note: Changing a username results in another local user being created. This is not a supported configuration.

Expected results:
Edit user fields should be grey'd out or hidden. Max running instances is the only valid field when in LDAP mode.
Comment 2 Mike Orazi 2012-09-25 10:53:52 EDT
*** Bug 859511 has been marked as a duplicate of this bug. ***
Comment 6 Tzu-Mainn Chen 2012-10-02 15:14:09 EDT
Pushed to master/1.1:

commit e135e79431e7cc94d7cbfba4c27b76eff67bfad2
Author: Tzu-Mainn Chen <tzumainn@redhat.com>
Date:   Tue Oct 2 14:12:23 2012 -0400

    BZ859998 disable certain fields from editing if in ldap mode
    
    Signed-off-by: Matt Wagner <matt.wagner@redhat.com>
    (cherry picked from commit 44e302962187474717d4b2e883d4f9d6dd15fdae)
Comment 7 Steve Linabery 2012-10-09 11:31:32 EDT
e135e79 on 1.1
Comment 9 Shveta 2012-10-10 20:41:48 EDT
Created attachment 625263 [details]
edit_user_in_ldap_mode

User is not allowed to edit in LDAP mode .
All Text fields are disabled .
However Save User Button is still active and if i click on it says "user Updated"
I suggest remove the edit button itself or Disable the "SaveUSer" button also
Comment 10 Tzu-Mainn Chen 2012-10-11 08:15:53 EDT
The reason the edit button is still there is because it's possible to edit the maximum running instances in both database and ldap mode.
Comment 12 errata-xmlrpc 2012-12-04 10:21:10 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.