Bug 860002 - Page selection of custom key info in system doesn't work
Page selection of custom key info in system doesn't work
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: WebUI (Show other bugs)
1.8
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Tomas Lestach
Red Hat Satellite QA List
:
Depends On:
Blocks: space18
  Show dependency treegraph
 
Reported: 2012-09-24 11:14 EDT by Krzysztof Pawłowski
Modified: 2012-11-01 12:20 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 890333 (view as bug list)
Environment:
Last Closed: 2012-11-01 12:20:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Krzysztof Pawłowski 2012-09-24 11:14:22 EDT
Description of problem: Page selectection in 'Systems -> XXX -> Details -> Custom info' doesn't work.


Version-Release number of selected component (if applicable):

spacewalk-pxt-1.8.36-1.el6.noarch spacewalk-java-postgresql-1.8.150-1.el6.noarch spacewalk-backend-xml-export-libs-1.8.69-1.el6.noarch spacewalk-backend-package-push-server-1.8.69-1.el6.noarch spacewalk-repo-1.8-3.el6.noarch spacewalk-certs-tools-1.8.2-1.el6.noarch spacewalk-backend-config-files-tool-1.8.69-1.el6.noarch spacewalk-postgresql-1.8.1-1.el6.noarch spacewalk-sniglets-1.8.36-1.el6.noarch spacewalk-html-1.8.36-1.el6.noarch spacewalk-doc-indexes-1.1.1-1.el6.noarch rhn-org-httpd-ssl-key-pair-spacewalk.icore-1.0-1.noarch spacewalk-branding-1.8.3-1.el6.noarch spacewalk-search-1.8.5-1.el6.noarch spacewalk-config-1.8.3-1.el6.noarch spacewalk-setup-1.8.17-1.el6.noarch spacewalk-base-minimal-1.8.36-1.el6.noarch spacewalk-java-config-1.8.150-1.el6.noarch spacewalk-backend-sql-1.8.69-1.el6.noarch spacewalk-backend-xmlrpc-1.8.69-1.el6.noarch spacewalk-schema-1.8.75-1.el6.noarch spacewalk-backend-iss-1.8.69-1.el6.noarch spacewalk-java-1.8.150-1.el6.noarch spacewalk-grail-1.8.36-1.el6.noarch spacewalk-java-oracle-1.8.150-1.el6.noarch spacewalk-monitoring-1.4.1-1.el6.noarch spacewalk-backend-1.8.69-1.el6.noarch spacewalk-backend-sql-oracle-1.8.69-1.el6.noarch spacewalk-backend-config-files-common-1.8.69-1.el6.noarch spacewalk-backend-tools-1.8.69-1.el6.noarch spacewalk-utils-1.8.28-1.el6.noarch spacewalk-backend-iss-export-1.8.69-1.el6.noarch spacewalk-taskomatic-1.8.150-1.el6.noarch spacewalk-common-1.8.1-1.el6.noarch spacewalk-backend-sql-postgresql-1.8.69-1.el6.noarch spacewalk-admin-1.8.5-1.el6.noarch spacewalk-backend-libs-1.8.69-1.el6.noarch spacewalk-backend-app-1.8.69-1.el6.noarch spacewalk-backend-config-files-1.8.69-1.el6.noarch spacewalk-setup-jabberd-1.8.6-1.el6.noarch spacewalk-monitoring-selinux-1.8.4-1.el6.noarch spacewalk-slf4j-1.6.1-1.el6.noarch spacewalk-base-1.8.36-1.el6.noarch spacewalk-java-lib-1.8.150-1.el6.noarch spacewalk-backend-server-1.8.69-1.el6.noarch spacewalk-selinux-1.8.2-1.el6.noarch spacewalk-backend-applet-1.8.69-1.el6.noarch spacewalk-jpp-workaround-1.0.4-1.el6.noarch


How reproducible:
Create more than 25 custom info key and try to add sth from second page to registered system.

Steps to Reproduce:
1. Click Systems
2. Click one of the systems
3. Click Details
4. Click Custom info
5. Click Create new value
6. Click next/last page icon  

Actual results:

Page Request Error

We could not display the requested page because of a missing parameter. This error could have occurred several ways:

    An incorrect or out-of-date bookmark.
    An incorrect or out-of-date hyperlink.
    Your browser encountered an error handling request parameters. Continued use of this browser may yield unexpected results.
    You've found an error in our site.

Expected results:

Switch to next page.

Additional info:
Comment 1 Tomas Lestach 2012-10-02 10:49:31 EDT
spacewalk.git: 759e9f31a5ac6c5c8147d00b18edc35b7188684e
Comment 2 Jan Pazdziora 2012-10-30 15:24:54 EDT
Moving ON_QA. Packages that address this bugzilla should now be available in yum repos at http://yum.spacewalkproject.org/nightly/
Comment 3 Jan Pazdziora 2012-11-01 12:20:19 EDT
Spacewalk 1.8 has been released: https://fedorahosted.org/spacewalk/wiki/ReleaseNotes18

Note You need to log in before you can comment on or make changes to this bug.