Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 860072 - common openshift-origin module not loading due to conflicts
common openshift-origin module not loading due to conflicts
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rubygem-openshift-origin-common (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Troy Dawson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-24 17:04 EDT by Troy Dawson
Modified: 2012-12-20 11:26 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 11:26:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Troy Dawson 2012-09-24 17:04:10 EDT
Description of problem:
stickshift selinux module not loading due to conflicts.

Version-Release number of selected component (if applicable):
ubygem-openshift-origin-common-0.13.3-11.fc18

How reproducible:
Always

Steps to Reproduce:
1. yum install rubygem-openshift-origin-common
2. semodule -i /usr/share/selinux/packages/rubygem-openshift-origin-common/stickshift.pp
3.
  
Actual results:
/etc/selinux/targeted/contexts/files/file_contexts: Multiple different specifications for /var/lib/stickshift(/.*)?  (system_u:object_r:stickshift_file_t:s0 and system_u:object_r:openshift_var_lib_t:s0).
/etc/selinux/targeted/contexts/files/file_contexts: Multiple same specifications for /var/lib/stickshift/.httpd.d(/.*)?.
/etc/selinux/targeted/contexts/files/file_contexts: Multiple different specifications for /var/log/mcollective\.log  (system_u:object_r:mcollectived_log_t:s0 and system_u:object_r:openshift_log_t:s0).
/etc/selinux/targeted/contexts/files/file_contexts: Invalid argument
libsemanage.semanage_install_active: setfiles returned error code 1.
semodule:  Failed!


Expected results:
The module should load with no output

Additional info:
Comment 1 Fedora Update System 2012-09-24 18:08:47 EDT
rubygem-openshift-origin-common-0.13.3-12.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/rubygem-openshift-origin-common-0.13.3-12.fc18
Comment 2 Fedora Update System 2012-09-25 02:04:36 EDT
Package rubygem-openshift-origin-common-0.13.3-12.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing rubygem-openshift-origin-common-0.13.3-12.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-14734/rubygem-openshift-origin-common-0.13.3-12.fc18
then log in and leave karma (feedback).
Comment 3 Fedora Update System 2012-12-20 11:26:08 EST
rubygem-openshift-origin-common-0.13.3-12.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.