Bug 860112 - [FCoE] Cannot create FCoE session for ixgbe in RHEL 5.
[FCoE] Cannot create FCoE session for ixgbe in RHEL 5.
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.8
All Linux
low Severity low
: rc
: ---
Assigned To: Neil Horman
Storage QE
: TechPreview
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-24 21:38 EDT by Gris Ge
Modified: 2013-05-16 00:21 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Known Issue
Doc Text:
The kernel in Red Hat Enterprise Linux 5 does not support Data Center Bridging (DCB). Software-based Fibre Channel over Etherner (FCoE) is a Technology Preview and it is therefore recommended to use Red Hat Enterprise Linux 6 for fully supported software-based FCoE. The following hardware-accelerated FCoE cards are fully supported in Red Hat Enterprise Linux 5: Emulex LPFC, QLogic qla2xxx, Brocade BFA.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-26 12:23:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Gris Ge 2012-09-24 21:38:33 EDT
Description of problem:

Bug #852340 fixed the kernel panic, but kernel still cannot setup FCoE session.
On FCoE switch, it already got FLOGI.

Version-Release number of selected component (if applicable):
Please check Bug #852340

How reproducible:
100%

Steps to Reproduce:
===
yum install -y fcoe-utils
service fcoe start

ifconfig eth2 up
ifconfig eth3 up
vconfig add eth2 802
vconfig add eth3 802
ifconfig eth2.802 up
ifconfig eth3.802 up

echo 'FCOE_ENABLE="yes"' > /etc/fcoe/cfg-eth2.802
echo 'DCB_REQUIRED="no"' >> /etc/fcoe/cfg-eth2.802
/bin/cp /etc/fcoe/cfg-eth2.802 /etc/fcoe/cfg-eth3.802 -f

service fcoe restart
===
  
Actual results:
No FCoE session created.

Expected results:
FCoE session created as expected.

Additional info:

Soft FCoE in RHEL 5 is tech-preview and kernel has no DCB support yet.
I (Storage-QE) am OK for closing this bug as WONTFIX.
Comment 2 Neil Horman 2012-09-25 10:20:15 EDT
This is way to involved for 5.9.  The fcoe code hasn't been touched since RHEL5 initially GA'ed.  I'm not even sure we should bother too much with it given its perpetual tech preview status in RHEL5
Comment 3 Neil Horman 2012-09-26 12:23:24 EDT
Updating fcoe in RHEL5 unless there is a specific customer need, doesn't seem worth it to me.  Doing so would require a several hundred patch series update to RHEL5 including the corresponding update to several major common components.  Given the tech-preview nature of FCoE in RHEL5 along with the age of the product, it doesn't seem worthwhile unless there is specific customer demand.  Please reopen if customer has a need for this

Note You need to log in before you can comment on or make changes to this bug.