Bug 860117 - RHUA Entitlement Gen Maps Selected Repos to Wrong Repos
RHUA Entitlement Gen Maps Selected Repos to Wrong Repos
Status: CLOSED ERRATA
Product: Red Hat Update Infrastructure for Cloud Providers
Classification: Red Hat
Component: RHUA (Show other bugs)
2.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: mkovacik
mkovacik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-24 22:56 EDT by Matthew Mariani
Modified: 2013-03-18 08:52 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
When generating an entitlement certificate for multiple custom repositories, the repositories listed for confirmation does not match the ones selected. This fix corrects the client.py so that correct custom entitlement confirmation is returned when generating entitlements.(BZ#860117)
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-28 10:38:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
First show the repos (113.59 KB, image/x-xcf)
2012-09-24 22:57 EDT, Matthew Mariani
no flags Details
Next shown the repos being confirmed - the "prod" repo should not be there. (110.31 KB, image/x-xcf)
2012-09-24 22:57 EDT, Matthew Mariani
no flags Details
Confirm by showing the DEV cluster detail. the "prod" custom repo is not associated with this cluster (90.46 KB, image/x-xcf)
2012-09-24 22:58 EDT, Matthew Mariani
no flags Details
RHUI update log (158.84 KB, text/plain)
2012-09-27 13:08 EDT, mkovacik
no flags Details
Verifying screen log (129.98 KB, text/plain)
2012-09-27 13:10 EDT, mkovacik
no flags Details

  None (edit)
Description Matthew Mariani 2012-09-24 22:56:16 EDT
Description of problem:
When generating an entitlement cert comprised of multiple custom repos, the repos are selected; however, when asked for confirmation the wrongs repos are selected.

Version-Release number of selected component (if applicable):
RHUI 2.1


How reproducible:
Create two CDS clusters, create multiple custom repos, try to create an entitlement RPM.  The final selected repos (those shown during confirmation) do not match those selected.


Steps to Reproduce:
1.  Create two CDS clusters
2.  Create multiple custom repos and associate with CDS cluster A
3.  Build an entitlement cert
4.  Select all the associated repos, complete information
5.  At the confirmation stage, observer the selected repos.  They do not match those selected previously. 
  
Actual results:
Invalid content entitlement and subsequent rpm

Expected results:
Correct content entitlement


Additional info:
Comment 1 Matthew Mariani 2012-09-24 22:57:06 EDT
Created attachment 616810 [details]
First show the repos
Comment 2 Matthew Mariani 2012-09-24 22:57:48 EDT
Created attachment 616811 [details]
Next shown the repos being confirmed - the "prod" repo should not be there.
Comment 3 Matthew Mariani 2012-09-24 22:58:26 EDT
Created attachment 616812 [details]
Confirm by showing the DEV cluster detail.  the "prod" custom repo is not associated with this cluster
Comment 4 James Slagle 2012-09-25 11:32:33 EDT
There was a bug in the process where we figured out which repos were actually selected.

Fixed in commit b4705a9f708039bd93c4818bbb7147809c1394b7
Comment 5 James Slagle 2012-09-25 11:41:37 EDT
built into rh-rhui-tools-2.1.13-1.el6_3, make sure you have this version when testing the update
Comment 6 James Slagle 2012-09-25 12:28:17 EDT
QA:
make sure you've updated to rh-rhui-tools-2.1.13.  Follow the RHUI update procedure as outlined in the RHUI Administration guide to get the updated package, however, sync your RHUI repos from cdn.rcm-qa.redhat.com instead of cdn.redhat.com in order to get this updated package.

Entitlement certificate creation needs to be thoroughly tested.  Have at least 2 clusters with different sets of custom repos (there should be some overlap, and also some repos that are also only on each cluster).

For each cluster, verify the list of repos to choose to include in an entitlement certificate is correct during certificate generation.  Choose various combinations during the certificate creation, such as:
- the first repo in the list
- the last repo in the list
- all custom repos
- no custom repos
- >1 repo in the list, but not all
- etc
Verify the entitlements for the correct repos you chose are displayed in the last question of the entitlement certificate generation where it asks you to confirm your choice.

Also verify the correct  repo entitlements were included in the entitlement certificate that was actually generated.  Use openssl to view the text content of the cert.
Comment 7 mkovacik 2012-09-27 13:08:48 EDT
Created attachment 618204 [details]
RHUI update log

Successfully updated to rh-rhui-tools-2.1.13-1.el6_3
Comment 8 mkovacik 2012-09-27 13:10:56 EDT
Created attachment 618205 [details]
Verifying screen log

The issue was solved having updated to rh-rhui-tools-2.1.13-1.el6_3

Notes
- verified in EC2 staging environment
- rh-rhui-tools-2.1.13-1.el6_3.noarch.rpm not signed
Comment 10 errata-xmlrpc 2012-09-28 10:38:28 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1315.html

Note You need to log in before you can comment on or make changes to this bug.