Bug 86015 - jumpy screeeensavers with dri
jumpy screeeensavers with dri
Status: CLOSED WONTFIX
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86 (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-12 09:49 EST by Sammy
Modified: 2007-04-18 12:51 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-02 23:12:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sammy 2003-03-12 09:49:54 EST
I am using XFree86-4.3.0-2.1 with a Radeon 7000 QY and a DELL 2000FP 
flat panel monitor doing 1600x1200 at 60Hz in analog mode. 
 
When I have the DRI  enabled most of the screensavers run very fast 
but in a way where the screen seems to refresh/flicker very rapidly. 
For example when I have the Atlantis (sharks swimming) the fish appear 
and disappear erratically, the same with mobious and other continuous 
motion screensavers. 
 
When I comment out the dri lines from the config file and the dri is 
disabled all of them work fine (except slower!).
Comment 1 Jason Tibbitts 2003-05-02 18:17:35 EDT
I have precisely the same problem.  I'm running an Athlon 2600+ with a Radeon
9000 (single screen only; no xinerama or really anything fancy at all):

01:00.0 VGA compatible controller: ATI Technologies Inc Radeon R250 If [Radeon
9000] (rev 01)
01:00.1 Display controller: ATI Technologies Inc Radeon R250 [Radeon 9000]
(Secondary) (rev 01)

I have tried both the stock Red Hat 9 XFree and the 4.3.0-5 packages released to
rawhide.  I have yet to try the newer 4.3.0-6 packages but will update as soon
as I can get them downloaded.

I'll try to explain the problem as well as I can.  Basically it looks as if
there's no double-buffering; since drawing is generally faster than the
monitor's refresh rate, what you see is fast snapshots of the image being
assembled.  So when the green gear is in front of the red gear, you can see some
of the red gear peeking through while the surface is being drawn.

What I find odd is that the problem doesn't appear with all of the GL
screensavers; gears, morph3d and moebius look absolutely horrible while euphoria
and particle fountain look beautiful.  I'm happy to test any other GL
applications as necessary.

Turning off DRI completely solves the problem, but then all 3D is slow.

Please let me know if there's any other information I can provide.

Comment 2 Mike A. Harris 2003-05-02 23:12:43 EDT
Please report this upstream to http://bugs.xfree86.org so that the DRI project
who writes and maintains DRI is aware of the issue and may perhaps address it
in a future release.
Comment 3 Jason Tibbitts 2003-05-15 14:05:10 EDT
So it turns out that (for me at least) this is a KDE bug.  Running, say, the
cage screensaver via xscreensaver-demo produces the expected smooth-as-glass
animation, while running it from the KScreensaver KControl module produces the
flickery mess.

Still WONTFIX?  I'll try to pursue this with the KDE folks, but I can't find any
mention of the problem in their bug database or on any of their mailing lists.

Note You need to log in before you can comment on or make changes to this bug.