Bug 860159 - [abrt] iok-2.1.3-2.fc18: strcmp: Process /usr/bin/iok was killed by signal 11 (SIGSEGV)
[abrt] iok-2.1.3-2.fc18: strcmp: Process /usr/bin/iok was killed by signal 11...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: iok (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Parag Nemade
Fedora Extras Quality Assurance
abrt_hash:c8ad6f048039a0ed32676f84207...
: Reopened
Depends On: 858591
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-25 03:12 EDT by Parag Nemade
Modified: 2012-10-16 00:00 EDT (History)
2 users (show)

See Also:
Fixed In Version: anaconda-18.16-1.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-16 00:00:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: core_backtrace (350 bytes, text/plain)
2012-09-25 03:12 EDT, Parag Nemade
no flags Details
File: environ (2.52 KB, text/plain)
2012-09-25 03:12 EDT, Parag Nemade
no flags Details
File: backtrace (68.85 KB, text/plain)
2012-09-25 03:12 EDT, Parag Nemade
no flags Details
File: limits (1.29 KB, text/plain)
2012-09-25 03:12 EDT, Parag Nemade
no flags Details
File: cgroup (128 bytes, text/plain)
2012-09-25 03:12 EDT, Parag Nemade
no flags Details
File: maps (39.00 KB, text/plain)
2012-09-25 03:12 EDT, Parag Nemade
no flags Details
File: dso_list (8.13 KB, text/plain)
2012-09-25 03:12 EDT, Parag Nemade
no flags Details
File: build_ids (3.64 KB, text/plain)
2012-09-25 03:12 EDT, Parag Nemade
no flags Details
File: var_log_messages (405 bytes, text/plain)
2012-09-25 03:13 EDT, Parag Nemade
no flags Details
File: open_fds (2.59 KB, text/plain)
2012-09-25 03:13 EDT, Parag Nemade
no flags Details

  None (edit)
Description Parag Nemade 2012-09-25 03:12:33 EDT
Description of problem:
1) start gnome-terminal 
2) run iok command in English locale


Version-Release number of selected component:
iok-2.1.3-2.fc18

Additional info:
libreport version: 2.0.14
abrt_version:   2.0.13
backtrace_rating: 4
cmdline:        iok
crash_function: strcmp
kernel:         3.6.0-0.rc6.git0.2.fc18.x86_64

truncated backtrace:
:Thread no. 1 (2 frames)
: #0 strcmp at ../sysdeps/x86_64/strcmp.S:213
: #1 create_IndicMapper at interface.c:10984
Comment 1 Parag Nemade 2012-09-25 03:12:37 EDT
Created attachment 616882 [details]
File: core_backtrace
Comment 2 Parag Nemade 2012-09-25 03:12:40 EDT
Created attachment 616883 [details]
File: environ
Comment 3 Parag Nemade 2012-09-25 03:12:43 EDT
Created attachment 616884 [details]
File: backtrace
Comment 4 Parag Nemade 2012-09-25 03:12:46 EDT
Created attachment 616885 [details]
File: limits
Comment 5 Parag Nemade 2012-09-25 03:12:49 EDT
Created attachment 616886 [details]
File: cgroup
Comment 6 Parag Nemade 2012-09-25 03:12:52 EDT
Created attachment 616887 [details]
File: maps
Comment 7 Parag Nemade 2012-09-25 03:12:55 EDT
Created attachment 616888 [details]
File: dso_list
Comment 8 Parag Nemade 2012-09-25 03:12:58 EDT
Created attachment 616889 [details]
File: build_ids
Comment 9 Parag Nemade 2012-09-25 03:13:01 EDT
Created attachment 616890 [details]
File: var_log_messages
Comment 10 Parag Nemade 2012-09-25 03:13:03 EDT
Created attachment 616891 [details]
File: open_fds
Comment 11 Parag Nemade 2012-09-25 04:58:18 EDT
After looking into source code its found that current locale set is not correct and this is due to current issues in F18 that is setting default English locale installation to POSIX locale.

This is not a bug. Once you reset LANG=en_US.UTF-8 and run iok, it works fine.
Comment 12 Parag Nemade 2012-10-02 23:48:24 EDT
Though this is not a bug in iok but in anaconda, anaconda package need to be fixed that automatically fixes this.
Comment 13 Parag Nemade 2012-10-16 00:00:01 EDT
Tested this with new anaconda-18.16-1.fc18

working fine.

Note You need to log in before you can comment on or make changes to this bug.