This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 86018 - Users get often a cookie error while logging in
Users get often a cookie error while logging in
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
unspecified
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mihai Ibanescu
Red Hat Satellite QA List
http://rhn.mediaways.net/
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-12 10:31 EST by Christian Stelter
Modified: 2007-07-31 15:10 EDT (History)
1 user (show)

See Also:
Fixed In Version: rhn400
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-30 13:54:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
httpd.conf - Apache Config (50.48 KB, text/plain)
2003-05-06 05:40 EDT, Christian Stelter
no flags Details
ifconfig output (1.56 KB, text/plain)
2003-05-06 05:41 EDT, Christian Stelter
no flags Details
host rhn.mediaways.net output (196 bytes, text/plain)
2003-05-06 05:42 EDT, Christian Stelter
no flags Details

  None (edit)
Description Christian Stelter 2003-03-12 10:31:09 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021202

Description of problem:
Sometimes we get cookies errors when logging into the satellite server via web
admin interface. This error persists normally. Sometimes even after restarting
the browser.


Version-Release number of selected component (if applicable):
rhns-server-1.2.6.1-5 rhn-satellite-admin-1.0-10

How reproducible:
Sometimes

Steps to Reproduce:
1. Go to https://rhn.mediaways.net/ or http://rhn.mediaways.net/
2. Login as user
3. Reload Login Page
4. Go to 2.
    

Actual Results:  cookie error


Expected Results:  Successful login.

Additional info:

It occurs with different browsers. NS 4.7, Mozilla 1.0 (release), Mozilla 1.2.1
(release) under Linux.
Comment 1 Mihai Ibanescu 2003-03-12 10:33:11 EST
Chip, any idea?
Comment 2 Christian Stelter 2003-04-03 06:15:50 EST
The problem persists. It seems to get even worse. :-/
Comment 3 Chip Turner 2003-04-21 08:40:41 EDT
are you certain the time on both the satellite and on the system running the
browser are both correct (including timezone, etc)?  also, the time on the
database server?

make sure you access the machine via its full domain name, ie, 'foo.bar.com' and
not just 'foo'.

also, what browser are you using?
Comment 4 Christian Stelter 2003-04-29 01:32:43 EDT
My client machine is 1 minute "faster" than the Satellite Server. Timezones are
correct.

I'm using:
Mozilla 1.2 / Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021202

The machine is accessed via its fqdn. 
Comment 5 Christian Stelter 2003-05-05 04:10:13 EDT
I suggest that we give you an account on our satellite server, so that you can
experience the effect for yourself.

Would that be a help for you?
Comment 6 Chip Turner 2003-05-05 08:33:18 EDT
can you ensure that the output of 'hostname' on the machine in question matches
the name you're using to access it?  if the machine is foo.bar.com, and
'hostname' only prints 'foo', then you will see problems similar to what you're
experiencing.
Comment 7 Christian Stelter 2003-05-05 09:10:34 EDT
The system's name (hostname is lnxc-115) has to match the name of the service
name (rhn.mediaways.net)? Why's that? 

And when this is the reason. Why does it happen not every time (but very often)? :-)

The apache (service) listens to rhn.mediaways.net it runs on its own virtual
interface (as virtual host on extra IP address). Does the application not
respect the effective server name under which it is running?
Comment 8 Chip Turner 2003-05-05 12:08:25 EDT
using the default httpd.conf that ships with the satellite, both would need to
match.  if you edited your httpd.conf to properly list VirtualHosts, however, it
shouldn't be an issue -- just as long as Apache knows that it can figure out the
FQDN of the current request.  if you've not updated your httpd.conf, though, but
simply have extra interfaces, you may need to modify it to understand what
hostnames are bound to what IPs.  please send your httpd.conf, the output if
"ifconfig", and the output of 'host rhn.mediaways.net'

also, cookie errors may show up if you wait a long time between loading the
login page and actually logging in; if you wait to type your username/password
for longer than cookie duration, the login handler won't see the cookie (since
it has expired already).  when the problem occurs, does immediately going back
to the main page (being sure to reload it) solve the issue?
Comment 9 Christian Stelter 2003-05-06 05:40:11 EDT
There's no long wait time between loading the start/login page and logging in.
Login follows immediately after loading the start/login page.

A single reload doesn't solve the problem. Only after serveral reloads it works
when the problem occurs.

See attachments for the requested data.
Comment 10 Christian Stelter 2003-05-06 05:40:50 EDT
Created attachment 91511 [details]
httpd.conf - Apache Config
Comment 11 Christian Stelter 2003-05-06 05:41:28 EDT
Created attachment 91512 [details]
ifconfig output
Comment 12 Christian Stelter 2003-05-06 05:42:10 EDT
Created attachment 91513 [details]
host rhn.mediaways.net output
Comment 13 Chip Turner 2003-05-08 14:14:59 EDT
do you get the cookie problems only through rhn.mediaways.net or also through
lnxc-115.srv.mediaways.net?  do you need to access it via both, or just the
rhn.mediaways.net address?

can you try removing the VirtualHost section, then change the ServerName setting
to be rhn.mediaways.net?
Comment 14 Christian Stelter 2003-05-09 04:32:23 EDT
When accessing the satellite server via lnxc-115.srv.mediaways.net there are no
cookie errors. Only while accessing it via rhn.mediaways.net. 

We've now removed all occurances of lnxc-115.srv.mediaways.net and we've forced
the apache to bind only to the one IP address of rhn.mediaways.net (which has
its own service ip).

That seems to do the trick. There are no cookie errors anymore. ;-)
Comment 15 Mihai Ibanescu 2005-09-30 13:54:34 EDT
Closing.

Note You need to log in before you can comment on or make changes to this bug.