Bug 860201 - persistent changes to policy fails with libselinux commit failed (No such file or directory)
persistent changes to policy fails with libselinux commit failed (No such fil...
Status: CLOSED DUPLICATE of bug 860172
Product: Fedora
Classification: Fedora
Component: policycoreutils (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 860127
  Show dependency treegraph
 
Reported: 2012-09-25 05:10 EDT by Pádraig Brady
Modified: 2012-09-25 05:28 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-25 05:28:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pádraig Brady 2012-09-25 05:10:51 EDT
policycoreutils-2.1.12-5.fc18.x86_64

Trying to set any bool persistently gives:

# setsebool -P virt_use_execmem on
libsemanage.bool_commit_list: libselinux commit failed (No such file or directory).
libsemanage.bool_commit_list: could not commit boolean list (No such file or directory).
libsemanage.dbase_activedb_flush: could not flush active database (No such file or directory).
libsemanage.semanage_commit_components: could not commit local/active modifications (No such file or directory).
Could not change policy booleans


Non persistent is fine:

# setsebool virt_use_execmem on
# getsebool virt_use_execmem
virt_use_execmem --> on
Comment 1 Miroslav Grepl 2012-09-25 05:28:11 EDT

*** This bug has been marked as a duplicate of bug 860172 ***

Note You need to log in before you can comment on or make changes to this bug.