Bug 860221 - haproxy needs static uid/gid assignment
haproxy needs static uid/gid assignment
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: setup (Show other bugs)
6.4
Unspecified Unspecified
medium Severity low
: rc
: ---
Assigned To: Ondrej Vasik
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-25 05:53 EDT by Ryan O'Hara
Modified: 2012-10-15 05:06 EDT (History)
3 users (show)

See Also:
Fixed In Version: setup-2.8.14-19.el6
Doc Type: Bug Fix
Doc Text:
Cause: haproxy is network load balancer and creates system user account haproxy. This account was created with dynamic assigned uid/gid. Consequence: Dynamic uid/gid assignment is not recommended for network daemons. Fix: Uid/gid pair 188:188 was reserved by setup package. Result: Haproxy package could create user haproxy with this static uid/gid.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-15 05:06:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ryan O'Hara 2012-09-25 05:53:09 EDT
Need static uid/gid for user/group 'haproxy'.

User: haproxy
Group: haproxy
Home: /var/lib/haproxy
Shell: /sbin/nologin
Comment 3 RHEL Product and Program Management 2012-09-25 11:28:55 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 5 Ondrej Vasik 2012-09-27 12:36:01 EDT
Just one question - which package creates the user/group haproxy?
Btw. you should have the static uid assignment only if the user/group owns/stores sensitive data or communicates via network/virtual machines. Otherwise is perfectly fine to have dynamic assignment. Given the fact that the username contains word proxy, I expect static would be better in this case.
Comment 6 Ryan O'Hara 2012-09-27 12:41:03 EDT
(In reply to comment #5)
> Just one question - which package creates the user/group haproxy?
> Btw. you should have the static uid assignment only if the user/group
> owns/stores sensitive data or communicates via network/virtual machines.
> Otherwise is perfectly fine to have dynamic assignment. Given the fact that
> the username contains word proxy, I expect static would be better in this
> case.

The haproxy package creates the haproxy user/group. You are correct in assuming that haproxy communicates over a network -- haproxy is a network load balancer. Thanks.
Comment 15 errata-xmlrpc 2012-10-15 05:06:58 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1367.html

Note You need to log in before you can comment on or make changes to this bug.