Bug 860238 - qemu qxl "hangs" when changing resolution
qemu qxl "hangs" when changing resolution
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Virtualization Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-25 07:26 EDT by Alexander Larsson
Modified: 2013-01-09 07:08 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-27 01:14:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fixes the problem (1.20 KB, patch)
2012-09-25 07:26 EDT, Alexander Larsson
no flags Details | Diff

  None (edit)
Description Alexander Larsson 2012-09-25 07:26:20 EDT
Created attachment 616975 [details]
Fixes the problem

With the latest qemu, if you change resolution in a guest that uses an older (v3) qxl driver then the guest qxl driver "hangs", meaning you can't further access the VM.

The reason for this is a bug in the qxl part of qemu when verifying qxl driver calls. See attached patch for details.
Comment 1 Fedora Update System 2012-09-25 16:32:26 EDT
qemu-1.2.0-10.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/qemu-1.2.0-10.fc18
Comment 2 Fedora Update System 2012-09-27 01:14:19 EDT
qemu-1.2.0-10.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.