Bug 860254 - Rhythmbox says it needs "vorbis decoder"
Rhythmbox says it needs "vorbis decoder"
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rhythmbox (Show other bugs)
18
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-25 07:56 EDT by Taylor Smock
Modified: 2012-10-13 05:31 EDT (History)
4 users (show)

See Also:
Fixed In Version: rhythmbox-2.98-3.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-12 01:16:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the terminal output from 'Ken Taylor' (21.63 KB, text/plain)
2012-10-05 03:38 EDT, Ken Taylor
no flags Details

  None (edit)
Description Taylor Smock 2012-09-25 07:56:48 EDT
Description of problem:
When attempting to play a .ogg file (which played on F17's version of Rhythmbox), it comes up with
"<<song name>> requires an additional plugin to decode this file

The following plugin is required:

Vorbis decoder"


Version-Release number of selected component (if applicable):
Rhythmbox 2.97, rhythmbox-2.97-5.fc18 (64 bit)

How reproducible:
Always


Steps to Reproduce:
1. Obtain ogg converted from mp3 (may not be necessary)
2. Attempt to play ogg with Rythmbox (fails)
3. Attempt to play ogg with Totem (works)
  
Actual results:
Pop-up asking to search for plugin.

Expected results:
Play the ogg file.


Additional info:
Comment 1 Ken Taylor 2012-10-04 14:29:53 EDT
I too am trying out the live nightly build of the 64-bit Fedora 18 on a live usb (using 'Fedora-18-Nightly-20121003.08-x86_64-Live-desktop.iso') and have found exactly the same as you with the addition that it won't play my '.flac' music files either.

The version of Rhythmbox is also 2.97, rhythmbox-2.97-5.fc18 (64 bit)

I too get pop-ups asking asking to search for plugins when i try and play .flac or .ogg music files:

For .flac files it says:
"The following plugin is required:
Free lossless audio codec (FLAC) decoder
Do you want to search for this now?"

For .ogg files it says:  
"The following plugin is required:
Vorbis decoder
Do you want to search for this now?"

Whether I choose to search for the missing plugin or not the file is not played but they both play fine with 'Movie player' etc.....
Comment 2 Ken Taylor 2012-10-05 03:38:59 EDT
Created attachment 621995 [details]
the terminal output from 'Ken Taylor'

I'd previously imported both a .flac and .ogg file of the same song into rythmbox, shut it down & started it again by typing "rhythmbox" in a terminal.

I tried playing:
.flac first then .ogg
.ogg first then .flac
.flac twice
.ogg twice. 

Each time:
~When you try and play the first song the dialogue pops up to ask if you want to search for a plug-in (but doesn't find one if you say yes).
~When you try and play the second song it crashes.

It makes no difference which order the songs are played in the result is always the same - the second song makes Rhythmbox crash.

I've attached the terminal output when i opened Rhythmbox and tried to play .flac then .ogg:
Comment 3 Fedora Update System 2012-10-11 08:32:19 EDT
rhythmbox-2.98-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/rhythmbox-2.98-3.fc18
Comment 4 Ken Taylor 2012-10-13 02:31:50 EDT
I've just tested this and it's sorted now, I had no problems at all, good work
Comment 5 Kalev Lember 2012-10-13 05:31:43 EDT
Excellent, thanks for testing!

Note You need to log in before you can comment on or make changes to this bug.