Bug 860276 - UnicodeEncodeError: 'ascii' codec can't encode character u'\xe9' in position 10: ordinal not in range(128)
UnicodeEncodeError: 'ascii' codec can't encode character u'\xe9' in position ...
Status: CLOSED DUPLICATE of bug 858591
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Sivák
Fedora Extras Quality Assurance
abrt_hash:271f48cbd34125b0ffee8a5b8cb...
: i18n
Depends On:
Blocks: F18Beta/F18BetaBlocker
  Show dependency treegraph
 
Reported: 2012-09-25 09:03 EDT by Martin
Modified: 2014-09-14 20:03 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-03 14:00:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: other involved packages (32 bytes, text/plain)
2012-09-25 09:03 EDT, Martin
no flags Details
File: type (9 bytes, text/plain)
2012-09-25 09:03 EDT, Martin
no flags Details
File: environ (131 bytes, text/plain)
2012-09-25 09:03 EDT, Martin
no flags Details
File: release (33 bytes, text/plain)
2012-09-25 09:03 EDT, Martin
no flags Details
File: hashmarkername (9 bytes, text/plain)
2012-09-25 09:03 EDT, Martin
no flags Details
File: firstboot-tb (2.35 KB, text/plain)
2012-09-25 09:03 EDT, Martin
no flags Details
File: description (1.19 KB, text/plain)
2012-09-25 09:03 EDT, Martin
no flags Details
/var/log/messages showing locale-related messages and a traceback (160.83 KB, text/plain)
2012-10-03 12:18 EDT, Steve Tyler
no flags Details
/var/log/messages when installing in English (296.23 KB, text/plain)
2012-10-03 14:43 EDT, Steve Tyler
no flags Details

  None (edit)
Description Martin 2012-09-25 09:03:05 EDT
Version-Release number of selected component:
firstboot-18.3-1.fc18.x86_64

Additional info:
libreport version: 2.0.12
cmdline:        /usr/bin/python  /usr/sbin/firstboot
kernel:         3.6.0-0.rc6.git0.2.fc18.x86_64
Comment 1 Martin 2012-09-25 09:03:08 EDT
Created attachment 617018 [details]
File: other involved packages
Comment 2 Martin 2012-09-25 09:03:10 EDT
Created attachment 617019 [details]
File: type
Comment 3 Martin 2012-09-25 09:03:12 EDT
Created attachment 617020 [details]
File: environ
Comment 4 Martin 2012-09-25 09:03:14 EDT
Created attachment 617021 [details]
File: release
Comment 5 Martin 2012-09-25 09:03:16 EDT
Created attachment 617022 [details]
File: hashmarkername
Comment 6 Martin 2012-09-25 09:03:18 EDT
Created attachment 617023 [details]
File: firstboot-tb
Comment 7 Martin 2012-09-25 09:03:20 EDT
Created attachment 617024 [details]
File: description
Comment 8 Adam Williamson 2012-09-26 16:45:04 EDT
Discussed at 2012-09-26 blocker review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-09-26/f18-beta-blocker-review-1.2012-09-26-16.03.log.txt . We agreed to delay decision on this one till we have more data. Martin, how did you trigger this?
Comment 9 Akira TAGOH 2012-09-26 21:17:22 EDT
After further investigation, this looks like a side-effect of Bug#858591. I tried to run firstboot from the terminal with LANG=ja_JP.UTF-8. no errors, but with LANG=ja.UTF-8, it happens.
Comment 10 Steve Tyler 2012-10-03 12:18:24 EDT
Created attachment 621011 [details]
/var/log/messages showing locale-related messages and a traceback

Reproduced by selecting Spanish as the language to be used during the install and for the installed system. /var/log/messages shows locale-related messages from firstboot and metacity and a traceback from firstboot.

Procedure:
1. In a VM, boot Fedora-18-Nightly-20120930.12-x86_64-Live-desktop.iso.
2. # yum update anaconda # install latest anaconda in live environment
3. Start the installer from the live desktop.
4. Select Spanish as the language to be used during installation and for the installed system.
5. Reboot into the installed system.

Results:
1. firstboot fails to start.
2. The locale files show invalid locales:

[root@localhost xfr]# cat /etc/sysconfig/i18n
LANG="es.UTF-8"
[root@localhost xfr]# cat /etc/locale.conf
LANG="es.UTF-8"

Version info:
anaconda-0:18.11-1.fc18.x86_64
firstboot-18.3-1.fc18.x86_64
Fedora-18-Nightly-20120930.12-x86_64-Live-desktop.iso

Command-line:
$ qemu-kvm -m 2048 -hda f18-test-2.img -cdrom ~/xfr/fedora/nightly-composes/Fedora-18-Nightly-20120930.12-x86_64-Live-desktop.iso -vga qxl -boot order=dc,menu=on
Comment 11 Adam Williamson 2012-10-03 14:00:39 EDT
I confirm this clearly seems to be a consequence of 858591. 'LC_ALL=es.UTF-8 firstboot' crashes, 'LC_ALL=es_ES.UTF-8 firstboot' runs. Closing this as a dupe of 858591. This also gives us a solid basis to accept 858591 as a blocker.

*** This bug has been marked as a duplicate of bug 858591 ***
Comment 12 Steve Tyler 2012-10-03 14:43:05 EDT
Created attachment 621069 [details]
/var/log/messages when installing in English

This may be moot, but it appears that if you install in English, you can get through firstboot and to a desktop despite the invalid en.UTF-8 locale. I'm attaching /var/log/messages from a test install with English as the target language in case someone wants to figure out why ...

Note You need to log in before you can comment on or make changes to this bug.