Bug 860278 - [abrt] firewalld-0.2.7-1.fc18: locale.py:539:setlocale:Error: unsupported locale setting
[abrt] firewalld-0.2.7-1.fc18: locale.py:539:setlocale:Error: unsupported loc...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: firewalld (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Thomas Woerner
Fedora Extras Quality Assurance
abrt_hash:7f9e4c203e8151b57bc8cf91f12...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-25 09:04 EDT by Martin
Modified: 2014-09-14 20:03 EDT (History)
5 users (show)

See Also:
Fixed In Version: firewalld-0.2.9-1.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-15 07:06:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: core_backtrace (285 bytes, text/plain)
2012-09-25 09:04 EDT, Martin
no flags Details

  None (edit)
Description Martin 2012-09-25 09:04:43 EDT
Version-Release number of selected component:
firewalld-0.2.7-1.fc18

Additional info:
libreport version: 2.0.12
abrt_version:   2.0.11
cmdline:        /usr/bin/python /usr/sbin/firewalld --nofork
kernel:         3.6.0-0.rc6.git0.2.fc18.x86_64

backtrace:
:locale.py:539:setlocale:Error: unsupported locale setting
:
:Traceback (most recent call last):
:  File "/usr/sbin/firewalld", line 32, in <module>
:    from firewall import config
:  File "/usr/lib/python2.7/site-packages/firewall/config/__init__.py", line 22, in <module>
:    locale.setlocale(locale.LC_ALL, "")
:  File "/usr/lib64/python2.7/locale.py", line 539, in setlocale
:    return _setlocale(category, locale)
:Error: unsupported locale setting
:
:Local variables in innermost frame:
:locale: ''
:category: 6
Comment 1 Martin 2012-09-25 09:04:45 EDT
Created attachment 617025 [details]
File: core_backtrace
Comment 2 Jiri Popelka 2012-09-25 09:17:00 EDT
Any idea what you were doing at the time of the crash ?
What's the output of 'locale' command ?
Comment 3 Martin 2012-09-25 14:05:23 EDT
Just firstbooted to latest Fedora 18.

locale:

    locale: Cannot set LC_CTYPE to default locale: No such file or directory
    locale: Cannot set LC_MESSAGES to default locale: No such file or directory
    locale: Cannot set LC_ALL to default locale: No such file or directory
    LANG=cs.UTF-8
    LC_CTYPE="cs.UTF-8"
    LC_NUMERIC="cs.UTF-8"
    LC_TIME="cs.UTF-8"
    LC_COLLATE="cs.UTF-8"
    LC_MONETARY="cs.UTF-8"
    LC_MESSAGES="cs.UTF-8"
    LC_PAPER="cs.UTF-8"
    LC_NAME="cs.UTF-8"
    LC_ADDRESS="cs.UTF-8"
    LC_TELEPHONE="cs.UTF-8"
    LC_MEASUREMENT="cs.UTF-8"
    LC_IDENTIFICATION="cs.UTF-8"
    LC_ALL=
Comment 4 Jiri Popelka 2012-09-26 06:05:21 EDT
cs.UTF-8 is not a correct locale, see 'locale -a | grep cs', that's probably anaconda's fault.

But firewalld shouldn't crash and should use the fallback 'C' locale.
Comment 5 Jiri Popelka 2012-09-26 06:26:50 EDT
Should be fixed upstream with this commit:
http://git.fedorahosted.org/cgit/firewalld.git/commit/?id=5c5eedeb73d79495e9cee2234db3ef8923a8ba5c
Comment 6 Steve Tyler 2012-09-29 00:50:37 EDT
After rebooting from a clean install using Fedora-18-Nightly-20120928.14-x86_64-Live-desktop.iso.

Package: firewalld-0.2.7-1.fc18
OS Release: Fedora release 18 (Spherical Cow)
Comment 7 Chuck Forsberg 2012-10-01 23:34:32 EDT
Happened upon clicking firewall applet

Package: firewall-config-0.2.8-1.fc18
OS Release: Fedora release 18 (Spherical Cow)
Comment 8 Steve Tyler 2012-10-02 00:49:12 EDT
A work-around seems to be to set the Language in "System Settings:Region & Language". After making that change you may need to reboot -- logging out and logging in again is no longer possible if there is only one user ... :-(

Verify with:
$ locale
Comment 9 Steve Tyler 2012-10-02 01:01:54 EDT
Cross-reference:
Bug 858591 - anaconda setting invalid system locale xx.UTF-8 not xx_YY.UTF-8
Comment 10 Steve Tyler 2012-10-02 14:41:37 EDT
(In reply to comment #8)
> A work-around seems to be to set the Language in "System Settings:Region &
> Language".
...

For a more complete work-around: Bug 858591, Comment 29.
Comment 11 Steve Tyler 2012-10-02 15:51:28 EDT
(In reply to comment #5)
> Should be fixed upstream with this commit:
> http://git.fedorahosted.org/cgit/firewalld.git/commit/
> ?id=5c5eedeb73d79495e9cee2234db3ef8923a8ba5c

It might be a good idea to write something to a log file. If the locale is not set or is incorrect, that could indicate a bug. And since firewalld is a security app, a locale error could indicate a hack of some sort ...

Note You need to log in before you can comment on or make changes to this bug.