Bug 860325 - default NFS version for ISO/Export domain should be NFS v3
default NFS version for ISO/Export domain should be NFS v3
Status: CLOSED DUPLICATE of bug 855729
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity urgent
: ---
: 3.1.0
Assigned To: Nobody's working on this, feel free to take it
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-25 11:25 EDT by Pavel Stehlik
Modified: 2016-02-10 12:43 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-26 19:22:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Stehlik 2012-09-25 11:25:00 EDT
Description of problem:
 Once the user create ISO domain as default - the negotiating version (in case vdsm 4.9.6 ) is NFS v4. This cause mount on host is nobody:nobody. The rest of workflow is trying to work with vdsm:kvm, however iso-uploader is pushing files as 640 - this cause inaccessible ISO file list. I think the same/similar will happen with DATA/EXPORT domain.

Version-Release number of selected component (if applicable):
si18.1 / vdsm 4.9.6-34

How reproducible:
100%

Steps to Reproduce:
1. have si18.1 & vdsm 4.9.6-34, create ISO domain
2. use iso-uploader & upload iso file
3.
  
Actual results:
the mount on host is nfs v4 with owner nobody:nobody

Expected results:
owner of mount on host vdsm:kvm

Additional info:
I am not sure this is problem iso-uploader as the mount is issue here. It could be maybe problematic with the rest operations as well (snapshots/import).
Comment 2 Itamar Heim 2012-09-26 19:22:59 EDT
actually, i'd go with bug 855729

*** This bug has been marked as a duplicate of bug 855729 ***

Note You need to log in before you can comment on or make changes to this bug.