Bug 860366 - heat-jeos "Cannot connect to Glance" error
heat-jeos "Cannot connect to Glance" error
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: heat-jeos (Show other bugs)
18
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Tomas Sedovic
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-25 13:23 EDT by Steven Hardy
Modified: 2013-12-13 14:34 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-13 14:34:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steven Hardy 2012-09-25 13:23:41 EDT
Description of problem:

Attempting to run heat-jeos with the --register-with-glance option results in an error connecting to glance, but the credentials and connection (via the glance CLI tool) seem fine.

[root@heattestlt ~]# heat-jeos create F17-x86_64-cfntools --register-with-glance
/bin/heat-jeos:32: UserWarning: The 'glance.client' module is deprecated in favor of the 'glanceclient' module provided by python-glanceclient (see http://github.com/openstack/python-glanceclient).
  from glance import client as glance_client
Cannot connect to Glance. Please verify that it's running and check your credentials.

[root@heattestlt ~]# glance index
ID                                   Name                           Disk Format          Container Format     Size          
------------------------------------ ------------------------------ -------------------- -------------------- --------------
61b70f02-b3ff-4869-aeaa-786de9a5170d F17-x86_64-cfntools            qcow2                bare                      647228928
1a1c7e4d-48e8-4c65-a788-a639295c22cb ami-tty                        ami                  ami                        25165824
0138a659-aed3-4b78-9b54-a7fdd224c135 ari-tty                        ari                  ari                         5882349
d39b1cd6-a173-494f-a42c-e1fd5fec915f aki-tty                        aki                  aki                         4404752
60994356-0f8e-44e1-9147-917b2ce3438c f16                            qcow2                bare                      213581824



Version-Release number of selected component (if applicable):

heat-jeos-6-1.fc18.noarch

How reproducible:
Always

Steps to Reproduce:
1.Run heat-jeos with the --register-with-glance option
2.Observe failure
  
Actual results:
Error connecting to glance

Expected results:
No error connecting to glance

Additional info:
Comment 1 Tomas Sedovic 2012-10-08 10:25:54 EDT
Seems to be related to this upstream issue:

https://github.com/heat-api/heat-jeos/issues/20
Comment 2 Steven Dake 2013-12-13 14:34:56 EST
heat-jeos is being removed from F21, so I'll close this bug.

Note You need to log in before you can comment on or make changes to this bug.