This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 860389 - NVC8 wont suspend
NVC8 wont suspend
Status: CLOSED DUPLICATE of bug 860248
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ben Skeggs
Kedar Bidarkar
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-25 13:55 EDT by Kedar Bidarkar
Modified: 2012-10-03 17:53 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-03 17:53:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
logs from NVC8 after suspend (416.12 KB, application/x-gzip)
2012-09-25 13:55 EDT, Kedar Bidarkar
no flags Details

  None (edit)
Description Kedar Bidarkar 2012-09-25 13:55:13 EDT
Created attachment 617159 [details]
logs from NVC8 after suspend

Description of problem:

system wont wake from suspend
Version-Release number of selected component (if applicable):

f18 xorg-x11-drv-nouveau-1.0.1-6.fc18.i686


How reproducible:

Try  suspend,

Steps to Reproduce:
1.
2.
3.
  
Actual results:

wont wake up from suspend

Expected results:
Should wake up from suspend



Additional info:

http://www.smolts.org/client/show/pub_63dc961d-4505-4335-bb22-0d9933c222fe
Comment 1 Ben Skeggs 2012-09-27 17:59:25 EDT
Is there any particular way to reproduce this reliably?  I have an NVC8 laptop here that I can't reproduce either of your bugs (the Xv one too) on :(
Comment 2 Ben Skeggs 2012-09-27 18:10:08 EDT
Actually, nevermind, I can randomly reproduce both issues.. This is going to be fun!
Comment 3 Ben Skeggs 2012-09-28 00:56:43 EDT
I've posted a kernel scratch build with a fix for the issue I was seeing on an NVC8 here: http://koji.fedoraproject.org/koji/taskinfo?taskID=4536222

I wasn't getting a GPU page fault from the COPY engine, but from the GRAPH engine instead.  Different symptoms, but perhaps same cause.  Would you be able to install and test it for me?
Comment 4 Kedar Bidarkar 2012-09-28 09:41:01 EDT
[root@localhost ~]# uname -a
Linux localhost.localdomain 3.6.0-0.rc7.git1.4.fc18.i686 #1 SMP Fri Sep 28 04:54:40 UTC 2012 i686 i686 i386 GNU/Linux
[root@localhost ~]# 


Awesome, suspend works perfect now. :)
Comment 5 Kedar Bidarkar 2012-09-28 09:44:23 EDT
I think I will also try this out by installing it on x86_64
Comment 6 Ben Skeggs 2012-09-28 17:02:13 EDT
Fantastic, I'll try and get the patch into 3.6 -fixes, which'll make its way into F18.  Failing that, I'll patch it in manually :)
Comment 7 Ben Skeggs 2012-10-03 17:53:23 EDT

*** This bug has been marked as a duplicate of bug 860248 ***

Note You need to log in before you can comment on or make changes to this bug.