Bug 86039 - upgraded RH errata kernel to 2.4.18-26smp breaks gdb thread traces
upgraded RH errata kernel to 2.4.18-26smp breaks gdb thread traces
Product: Red Hat Linux
Classification: Retired
Component: gdb (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Elena Zannoni
Jay Turner
Depends On:
  Show dependency treegraph
Reported: 2003-03-12 16:36 EST by Dave Johnson
Modified: 2015-01-07 19:04 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2003-03-20 22:20:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Dave Johnson 2003-03-12 16:36:05 EST
Description of problem:
After upgrading from 2.4.18-5smp to 2.4.18-26smp, multithreaded apps can
no longer be gdb'ed.  when one does "info threads" it comes back with

One of the developer that writes all their things multithreaded noticed
this has occured with other people under different circumstances (links listed 
in other information category below).  Nobody has a resolution or insight into 
fixing it other than trying different versions of glibc and/or gdb.  (We tried 
different versions of gdb, to little luck).  

Tried gdb with standard 7.3, the updated errata gdb for 7.3, as well as
the rawhide version, same deal.

Should it matter if the apps are compiled with gcc3.2?

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. gdb <multitreaded app>
2. info threads
3. get back nothing.
Actual results:

Expected results:
list of threads and ability to get individual thread stack traces.

Additional info:


Comment 1 Elena Zannoni 2003-03-12 17:47:03 EST
Probably a libthread_db mismatch with the kernel. Need the appropriate glibc.
Nothing to do with gdb. 

Comment 2 Dave Johnson 2003-03-13 14:31:59 EST
You can close this.  Glibc version was fine, user should not specify /lib in 
LD_LIBRARY_PATH at all.  User can still specify other lib dirs, but just don't 
put /lib in.  This will "override" the system from "automatically" 
choosing /lib/i686/libc vs. /lib/libc.

Note You need to log in before you can comment on or make changes to this bug.