Bug 860397 - new /etc/sudo-ldap.conf configuration file problems
new /etc/sudo-ldap.conf configuration file problems
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sudo (Show other bugs)
6.3
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Daniel Kopeček
Aleš Mareček
:
Depends On:
Blocks: 982702
  Show dependency treegraph
 
Reported: 2012-09-25 14:08 EDT by Rob Crittenden
Modified: 2013-07-09 11:38 EDT (History)
3 users (show)

See Also:
Fixed In Version: sudo-1.8.6p3-6.el6
Doc Type: Bug Fix
Doc Text:
Cause: Wrong file permissions on /etc/sudo-ldap.conf and missing examples in the same file. Consequence: Inconsistency with Red Hat provided documentation. Fix: Corrected file permissions and added example configuration lines. Result: Restored consistency with Red Hat documentation.
Story Points: ---
Clone Of:
: 982702 (view as bug list)
Environment:
Last Closed: 2013-02-21 04:44:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rob Crittenden 2012-09-25 14:08:47 EDT
Description of problem:

First two problems moved over from BZ https://bugzilla.redhat.com/show_bug.cgi?id=860386

1. The newly installed /etc/sudo-ldap.conf has some of the entries from the old /etc/nslcd.conf, but not all. However, all the entries from the documentation are needed. It would be nice is that is reflected in the file commented out entries.

2. The permissions of /etc/sudo-ldap does not seem to be correct. It is 440. Shouldn't it be 640?

3. There is no man page for sudo-ldap.conf

4. sudo-ldap.conf is not mentioned in the sudo man page.

Version-Release number of selected component (if applicable):

sudo-1.7.4p5-13.el6_3

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 Daniel Kopeček 2012-09-26 08:22:19 EDT
Hi,

(In reply to comment #0)
> Description of problem:
> 
> First two problems moved over from BZ
> https://bugzilla.redhat.com/show_bug.cgi?id=860386
> 
> 1. The newly installed /etc/sudo-ldap.conf has some of the entries from the
> old /etc/nslcd.conf, but not all. However, all the entries from the
> documentation are needed. It would be nice is that is reflected in the file
> commented out entries.

could you please provide the list of additional entries that should be in the sudo-ldap.conf file? The configuration file now contains the most important once and they are commented out.

> 3. There is no man page for sudo-ldap.conf
> 4. sudo-ldap.conf is not mentioned in the sudo man page.

It's referenced from the README.LDAP file which is part of the documentation that gets installed on the system.
Comment 4 Daniel Kopeček 2012-09-26 09:07:18 EDT
(In reply to comment #2)
> > 3. There is no man page for sudo-ldap.conf
> > 4. sudo-ldap.conf is not mentioned in the sudo man page.
> 
> It's referenced from the README.LDAP file which is part of the documentation
> that gets installed on the system.

And also from man sudoers.ldap
Comment 6 Daniel Kopeček 2012-09-26 10:41:12 EDT
Changes made:
1. corrected file permissions to 0640
2. added commented out option to sudo-ldap.conf:
   #binddn uid=sudo,cn=sysaccounts,cn=etc,dc=example,dc=com
   #bindpw secret
   #ssl start_tls
   #tls_cacertfile /path/to/CA.crt
   #tls_checkpeer yes
Comment 13 errata-xmlrpc 2013-02-21 04:44:48 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0363.html

Note You need to log in before you can comment on or make changes to this bug.