Bug 860428 - duplicated step in deploy application wizard
duplicated step in deploy application wizard
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.1.0
Unspecified Unspecified
unspecified Severity medium
: beta6
: ---
Assigned To: Imre Farkas
Dave Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-25 15:30 EDT by Dave Johnson
Modified: 2012-12-04 10:21 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
When launching an application through the Application Details page, a dropdown box called "Cloud Resource Selection" appeared erroneously. This update removes the dropdown box from this screen.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 10:21:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
new page in wizard (33.36 KB, image/png)
2012-09-25 15:30 EDT, Dave Johnson
no flags Details
expected page (38.24 KB, image/png)
2012-09-25 15:31 EDT, Dave Johnson
no flags Details
Page changed (52.12 KB, image/png)
2012-10-10 19:01 EDT, Shveta
no flags Details
cluster_selection (60.09 KB, image/png)
2012-10-16 12:33 EDT, Shveta
no flags Details
cluster_selection_removed (52.80 KB, image/png)
2012-10-23 14:04 EDT, Shveta
no flags Details

  None (edit)
Description Dave Johnson 2012-09-25 15:30:12 EDT
Description of problem:
===================================
Starting with Monday's build, the test automation is tripping up on launch a application from the application details page (clicking the launch button).  I debugged the issue down to a new step in the "wizard" has been added and looking at it, the step looks like its roughly a duplicate of the last (expected) page so curious if this was on purpose because it seems like it is not needed.

refer to the screen shots, the new page now displays before the final page (which is the one the automation has been coded for up to this point).


Version-Release number of selected component (if applicable):
=================================================================
aeolus-conductor-0.13.14-1.el6cf.noarch
Comment 1 Dave Johnson 2012-09-25 15:30:59 EDT
Created attachment 617226 [details]
new page in wizard
Comment 2 Dave Johnson 2012-09-25 15:31:25 EDT
Created attachment 617227 [details]
expected page
Comment 5 Imre Farkas 2012-10-01 06:42:58 EDT
It's not a duplicated step, this workflow is the same as starting a new deployment from the Monitor page. Previously, launching from deployables#show  redirected to the second page of the wizard and set the deployment name to the same name as the deployable had. It was changed because of #859503
Comment 6 Dave Johnson 2012-10-03 11:58:34 EDT
It is duplicated... the name and cluster selections definitely are, just curious on why this cannot all be on a single page.
Comment 7 Imre Farkas 2012-10-04 08:49:01 EDT
It's not duplicated. You should not be able to do the cluster selection on the second page, you are only allowed to to that only on the first step. Could you explain the steps necessary for changing the cluster on both the first and the second page of the workflow? I can't reproduce it.

The second page is the overview of deployment which is about to launch. You have only the option to change its name.
Comment 8 Giulio Fidente 2012-10-10 11:17:11 EDT
Using aeolus-conductor-0.13.18-1.el6cf I'm seeing the same behaviour Dave reported. In the last step of the launch wizard I was allowed to change the cluster. The application was actually deployed on the cluster I selected last.
Comment 9 Shveta 2012-10-10 19:01:49 EDT
Created attachment 625227 [details]
Page changed

Checked in puddle 4 , the second page does not have cluster selection .

 rpm -qa|grep aeolus
aeolus-conductor-0.13.18-1.el6cf.noarch
aeolus-conductor-daemons-0.13.18-1.el6cf.noarch
aeolus-configure-2.8.9-1.el6cf.noarch
aeolus-all-0.13.18-1.el6cf.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-conductor-doc-0.13.18-1.el6cf.noarch
rubygem-aeolus-cli-0.7.4-1.el6cf.noarch
Comment 10 Shveta 2012-10-16 12:33:31 EDT
Re-Opening this bug ..
Seeing it again ..



rpm -qa|grep aeolus
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-conductor-daemons-0.13.18-1.el6cf.noarch
rubygem-aeolus-cli-0.7.4-1.el6cf.noarch
aeolus-conductor-doc-0.13.18-1.el6cf.noarch
aeolus-all-0.13.18-1.el6cf.noarch
aeolus-configure-2.8.9-1.el6cf.noarch
Comment 11 Shveta 2012-10-16 12:33:58 EDT
Created attachment 628260 [details]
cluster_selection
Comment 12 Imre Farkas 2012-10-17 07:52:52 EDT
Pull request sent to remove the realm selection dropbox:
https://github.com/aeolusproject/conductor/pull/130
Comment 13 Scott Seago 2012-10-19 15:29:36 EDT
Acked and merged the pull request.
Comment 14 Steve Linabery 2012-10-22 14:48:20 EDT
c2272b41008c50c7ba107ec24e4cc519cc2378f4 on 1.1
df705c849eb4b9c2fd04fa8ec32700fee39406b7 on master
Comment 16 Shveta 2012-10-23 14:04:49 EDT
Created attachment 632247 [details]
cluster_selection_removed
Comment 17 Shveta 2012-10-23 14:05:13 EDT
rpm -qa|grep aeolus
rubygem-aeolus-image-0.3.0-12.el6.noarch
rubygem-aeolus-cli-0.7.5-1.el6cf.noarch
aeolus-conductor-doc-0.13.20-1.el6cf.noarch
aeolus-configure-2.8.9-1.el6cf.noarch
aeolus-conductor-daemons-0.13.20-1.el6cf.noarch
aeolus-all-0.13.20-1.el6cf.noarch
aeolus-conductor-0.13.20-1.el6cf.noarch
Comment 19 errata-xmlrpc 2012-12-04 10:21:33 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.