Bug 860453 - system-config-language crashes when setting locale without language group
system-config-language crashes when setting locale without language group
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: system-config-language (Show other bugs)
18
Unspecified Linux
unspecified Severity high
: ---
: ---
Assigned To: anish
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-25 16:51 EDT by Álvaro Castillo
Modified: 2015-04-12 19:12 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 10:15:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Álvaro Castillo 2012-09-25 16:51:28 EDT
Description of problem:

s-c-l is good tool to change your language on your PC

Version-Release number of selected component (if applicable):
=========================
s-c-l
Version     : 1.3.5
Release     : 13.fc18
=========================
yum
Version     : 3.4.3
Release     : 44.fc18
=========================

How reproducible:


Steps to Reproduce:
1. Install s-c-l on your Fedora 18 Alpha with all updates
2. Run s-c-l
Comment 1 xset1980 2012-09-25 22:41:36 EDT
I can confirm it.

system-config-language-1.3.5-13.fc18.noarch
Fedora 18 Alpha KDE spin up to date.

1.- Run system-config-language
2.- Select spanish from spain
3.- put OK
4.- The GUI say: "No Group named spanish-support exists: Do you still want to install language without proper support?
5.- Yes is pressed
6.- The App GUI crash and not respond and the only way for recall is ctrl+c from the terminal that started s-c-l

Reproducible: Always

Other languages like finnish works, downloading the necessary packages and installing it. Spanish group, no.
Comment 2 xset1980 2012-09-25 22:58:48 EDT
Additional Info:

After select, english, again, spanish from spain, later finnish, and again Spanish from spain and wait 5 minutes, works. If spanish from spain is selected in first instance, not.
Comment 3 Álvaro Castillo 2012-10-16 10:17:52 EDT
So, is a bug
Comment 4 Pravin Satpute 2012-10-16 10:42:37 EDT
I can also reproduce same.

$yum langinstall es_ES, works fine. 

i think s-c-l should call groupinstall and langinstall both commands irrespective of language group present or not.
Comment 5 anish 2012-11-02 08:48:33 EDT
thanks for the bug, can you please try with lastest version of yum and s-c-l.
I am not able to reproduce the issue.
Checked with Pravin Satpute as well, he is also not able to reproduce it
Comment 6 Fedora Update System 2012-11-02 08:52:00 EDT
system-config-language-1.3.5-14.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/system-config-language-1.3.5-14.fc18
Comment 7 Fedora Update System 2012-11-02 08:52:35 EDT
system-config-language-1.3.5-14.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/system-config-language-1.3.5-14.fc17
Comment 8 Fedora Update System 2012-11-02 14:37:41 EDT
Package system-config-language-1.3.5-14.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing system-config-language-1.3.5-14.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-17506/system-config-language-1.3.5-14.fc18
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2012-12-20 10:15:23 EST
system-config-language-1.3.5-14.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.