Bug 860467 - spacewalk-clone-by-date needs a better description of what it does
spacewalk-clone-by-date needs a better description of what it does
Status: CLOSED ERRATA
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
550
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Jan Pazdziora
Dimitar Yordanov
: Patch
Depends On:
Blocks: 819027
  Show dependency treegraph
 
Reported: 2012-09-25 17:54 EDT by Peter Gervase
Modified: 2013-01-18 08:47 EST (History)
3 users (show)

See Also:
Fixed In Version: spacewalk-utils-1.7.15-39-sat
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-18 08:47:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
patch to add information to the man page (1.05 KB, patch)
2012-09-25 17:54 EDT, Peter Gervase
no flags Details | Diff

  None (edit)
Description Peter Gervase 2012-09-25 17:54:11 EDT
Created attachment 617277 [details]
patch to add information to the man page

Description of problem:
The documentation on what spacewalk-clone-by-date exactly does (and doesn't do) is a bit lacking. 

The man page starts off with, 
"       Script to clone software channels and errata up to specific dates ensuring any added packages have their dependencies satisfied. Any destination channels
       that do not exist will be created.
"
but doesn't go into much detail or talk about cloning errata.

Version-Release number of selected component (if applicable):
spacewalk-utils-1.7.15-37.el6sat.noarch


How reproducible:
100%

Steps to Reproduce:
1. install the spacewalk-utils package
2. man spacewalk-clone-by-date
3.
  
Actual results:
See a man page with more detail

Expected results:
The man page doesn't have enough detail.

Additional info:
Attached is my patch, approved by the customer having this question:
Comment 2 Jan Pazdziora 2012-09-26 07:25:35 EDT
Patch applied to Spacewalk master, dd1a3cdc3b73c6b2b3f0bacd30f0b594d5658c22.
Comment 6 errata-xmlrpc 2013-01-18 08:47:04 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0167.html

Note You need to log in before you can comment on or make changes to this bug.