Bug 860476 - RFE: support lvcreate thin provisioning
RFE: support lvcreate thin provisioning
Status: CLOSED DUPLICATE of bug 1060287
Product: Virtualization Tools
Classification: Community
Component: libvirt (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Libvirt Maintainers
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-25 18:30 EDT by joshua
Modified: 2016-04-13 17:19 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-13 17:19:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
creating a new storage volume with virt-manager (34.62 KB, image/png)
2012-09-25 18:33 EDT, joshua
no flags Details

  None (edit)
Description joshua 2012-09-25 18:30:50 EDT
Description of problem:

virt-manager, after adding an LVM-based storage pool, doesn't actually create thin Logical Volumes... even when specifying it to do so.   See attached picture.


What's more, if a thinpool VL exists, virt-manager refused to even allow the creation of an LVM storage pool using that Volume Group:
# lvcreate VolGrpSlow0 --thinpool lv_thinpool --size 100G





Version-Release number of selected component (if applicable):

virt-manager-0.9.4-1.fc17.noarch
Comment 1 joshua 2012-09-25 18:33:30 EDT
Created attachment 617295 [details]
creating a new storage volume with virt-manager

Max Capacity at 9000 megs, but currently allocation at 0... yet the LV create is just plain old 9000 megs... not thin provisioned
Comment 2 joshua 2012-09-25 18:47:12 EDT
To clarify, I'm using an already existing Volume Group, with other LVs on it.  

This works fine expect for the thin provisioning.
Comment 3 Cole Robinson 2012-10-13 21:38:11 EDT
We are requesting it, libvirt just needs to support it. But I guess this is a fairly new feature so we would need to be careful to maintain back compat:


http://www.redhat.com/archives/lvm-devel/2012-March/msg00062.html
http://fedoraproject.org/wiki/Features/ThinProvisioning
Comment 4 Steven Ellis 2015-04-23 18:40:26 EDT
Any progress on this as virt-manager can't even see existing thin LVs.

For example  
 - Create Thin Pool
 - Create Thin LV
 - Create a new VM via virt-manager and manually select the Thin VG as the Disk
 - virt-manager  deletes the Thin LV and creates a new FAT LV with the same name.
Comment 5 Cole Robinson 2016-04-13 17:19:01 EDT
(In reply to Steven Ellis from comment #4)
> Any progress on this as virt-manager can't even see existing thin LVs.
> 
> For example  
>  - Create Thin Pool
>  - Create Thin LV
>  - Create a new VM via virt-manager and manually select the Thin VG as the
> Disk
>  - virt-manager  deletes the Thin LV and creates a new FAT LV with the same
> name.

steven, if you are still hitting unexpected virt-manager behavior, please file a bug against virt-manager and list your virt-manager + libvirt versions

As for this bug, just duping to the feature request being tracked under product=RHEL7 since that's where all the interesting info is

*** This bug has been marked as a duplicate of bug 1060287 ***

Note You need to log in before you can comment on or make changes to this bug.