Bug 860507 - VDSM doesn't show the correct number of cores in my hypervisor (nested kvm)
VDSM doesn't show the correct number of cores in my hypervisor (nested kvm)
Status: CLOSED DUPLICATE of bug 833425
Product: oVirt
Classification: Community
Component: vdsm (Show other bugs)
3.1 RC
All Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Douglas Schilling Landgraf
Haim
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-25 22:25 EDT by Marcelo Barbosa "firemanxbr"
Modified: 2014-01-12 19:54 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-03 13:17:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs from my hypervisor (11.14 KB, application/x-gzip)
2012-09-25 22:25 EDT, Marcelo Barbosa "firemanxbr"
no flags Details

  None (edit)
Description Marcelo Barbosa "firemanxbr" 2012-09-25 22:25:11 EDT
Created attachment 617354 [details]
logs from my hypervisor

Description of problem:
Engine/vdsClient doesn't show the correct number of cores in my hypervisor (nested kvm)

Version-Release number of selected component (if applicable):
ovirt 3.1 GA

How reproducible:
1- Install ovirt 3.1 node and engine as virtual machine using virt-manager + nested kvm. 

2 - Register the hypervisor in Engine

3 - Notice that cpu cores info shows 1 cpu core instead of 7 (from my i7 intel)

Actual results:
vdsm detects one cpu instead of 7 (from my i7 intel)

Expected results:
vdsm detect 7 cpu cores

Additional info:
Attached cpuinfo and /sys from hypervisor

[root@PROD-OvirtHypervisor ~]# rpm -qa | grep vdsm
vdsm-gluster-4.10.0-0.456.gitc1428a3.fc17.noarch
vdsm-hook-faqemu-4.10.0-0.456.gitc1428a3.fc17.noarch
vdsm-hook-vhostmd-4.10.0-0.456.gitc1428a3.fc17.noarch
vdsm-xmlrpc-4.10.0-0.456.gitc1428a3.fc17.noarch
vdsm-4.10.0-0.456.gitc1428a3.fc17.x86_64
vdsm-hook-qemucmdline-4.10.0-0.456.gitc1428a3.fc17.noarch
vdsm-cli-4.10.0-0.456.gitc1428a3.fc17.noarch
vdsm-python-4.10.0-0.456.gitc1428a3.fc17.x86_64

[root@PROD-OvirtHypervisor ~]# vdsClient -s 0 getVdsCaps 

	HBAInventory = {'iSCSI': [{'InitiatorName': 'iqn.1994-05.com.redhat:6ebfdef9e73b'}], 'FC': []}
	ISCSIInitiatorName = iqn.1994-05.com.redhat:6ebfdef9e73b
	bondings = {'bond4': {'addr': '', 'cfg': {}, 'mtu': '1500', 'netmask': '', 'slaves': [], 'hwaddr': '00:00:00:00:00:00'}, 'bond0': {'addr': '', 'cfg': {}, 'mtu': '1500', 'netmask': '', 'slaves': [], 'hwaddr': '00:00:00:00:00:00'}, 'bond1': {'addr': '', 'cfg': {}, 'mtu': '1500', 'netmask': '', 'slaves': [], 'hwaddr': '00:00:00:00:00:00'}}
	bridges = {'ovirtmgmt': {'addr': '192.168.122.167', 'cfg': {'DEVICE': 'ovirtmgmt', 'DELAY': '0', 'BOOTPROTO': 'dhcp', 'ONBOOT': 'yes', 'NM_CONTROLLED': 'no'}, 'mtu': '1500', 'netmask': '255.255.255.0', 'stp': 'off', 'ports': ['eth0']}}
	clusterLevels = ['3.0', '3.1', '3.2']
	cpuCores = 1
	cpuFlags = fpu,vme,de,pse,tsc,msr,pae,mce,cx8,apic,sep,mtrr,pge,mca,cmov,pat,pse36,clflush,mmx,fxsr,sse,sse2,ss,syscall,nx,rdtscp,lm,constant_tsc,arch_perfmon,rep_good,nopl,pni,pclmulqdq,vmx,ssse3,cx16,sse4_1,sse4_2,x2apic,popcnt,aes,avx,hypervisor,lahf_lm,model_Nehalem,model_Conroe,model_Penryn,model_Westmere
	cpuModel = Intel(R) Core(TM)2 Duo CPU     T7700  @ 2.40GHz
	cpuSockets = 1
	cpuSpeed = 3392.296
	emulatedMachines = ['pc-0.15', 'pc-1.0', 'pc', 'pc-0.14', 'pc-0.13', 'pc-0.12', 'pc-0.11', 'pc-0.10', 'isapc', 'pc-0.15', 'pc-1.0', 'pc', 'pc-0.14', 'pc-0.13', 'pc-0.12', 'pc-0.11', 'pc-0.10', 'isapc']
	guestOverhead = 65
	hooks = {'before_vm_migrate_destination': {'50_vhostmd': {'md5': 'f3ee6dbf6fbd01333bd3e32afec4fbba'}}, 'before_vm_start': {'50_qemucmdline': {'md5': 'a884929ad6f5eb039887157288867409'}, '50_vhostmd': {'md5': 'f3ee6dbf6fbd01333bd3e32afec4fbba'}, '10_faqemu': {'md5': 'c899c5a7004c29ae2234bd409ddfa39b'}}, 'after_vdsm_stop': {'10_faqemu': {'md5': '492b794a53ae549ed660dc000a1bb34f'}}, 'before_vm_dehibernate': {'50_vhostmd': {'md5': 'f3ee6dbf6fbd01333bd3e32afec4fbba'}}, 'after_vm_destroy': {'50_vhostmd': {'md5': '5662659ddc999e23946a1f6cf7a73796'}}}
	kvmEnabled = true
	lastClient = 192.168.122.128
	lastClientIface = ovirtmgmt
	management_ip = 
	memSize = 11010
	netConfigDirty = False
	networks = {'ovirtmgmt': {'iface': 'ovirtmgmt', 'addr': '192.168.122.167', 'cfg': {'DEVICE': 'ovirtmgmt', 'DELAY': '0', 'BOOTPROTO': 'dhcp', 'ONBOOT': 'yes', 'NM_CONTROLLED': 'no'}, 'mtu': '1500', 'netmask': '255.255.255.0', 'stp': 'off', 'bridged': True, 'gateway': '192.168.122.1', 'ports': ['eth0']}}
	nics = {'eth0': {'addr': '', 'cfg': {'DEVICE': 'eth0', 'HWADDR': '52:54:00:c4:6b:d2', 'BOOTPROTO': 'none', 'ONBOOT': 'yes', 'BRIDGE': 'ovirtmgmt'}, 'mtu': '1500', 'netmask': '', 'hwaddr': '52:54:00:c4:6b:d2', 'speed': 0}}
	operatingSystem = {'release': '1', 'version': '17', 'name': 'Fedora'}
	packages2 = {'kernel': {'release': '2.fc17.x86_64', 'buildtime': 1342749256.0, 'version': '3.4.6'}, 'spice-server': {'release': '5.fc17', 'buildtime': 1336983054, 'version': '0.10.1'}, 'vdsm': {'release': '0.456.gitc1428a3.fc17', 'buildtime': 1348263843, 'version': '4.10.0'}, 'qemu-kvm': {'release': '1.fc17', 'buildtime': 1343612073, 'version': '1.0.1'}, 'libvirt': {'release': '2.fc17', 'buildtime': 1347185542, 'version': '0.10.1'}, 'qemu-img': {'release': '1.fc17', 'buildtime': 1343612073, 'version': '1.0.1'}}
	reservedMem = 321
	software_revision = 0.456
	software_version = 4.10
	supportedProtocols = ['2.2', '2.3']
	supportedRHEVMs = ['3.0', '3.1']
	uuid = 744142BE-6D96-99A2-76E9-3717BF182255_52:54:00:c4:6b:d2
	version_name = Snow Man
	vlans = {}
	vmTypes = ['kvm']
Comment 1 Douglas Schilling Landgraf 2012-09-25 22:33:47 EDT
Hi,

Amador's patch from BZ#833425 should resolve this case too. I would close this one as duplicate of BZ#833425. Amador would you like to add a comment about this report?

Thanks
Douglas
Comment 2 Amador Pahim 2012-09-26 06:44:32 EDT
Hi,

Here physical id and core id are missing in cpuinfo. /sys seems ok. Since the patch http://gerrit.ovirt.org/#/c/5481/ changes vdsm cpu topology probe from cpuinfo to /sys, it will bypass this and return the right information.

Best,
Amador.
Comment 3 Douglas Schilling Landgraf 2012-10-03 13:17:04 EDT
Hi Marcelo,


   Thanks for your report. I am going to close this bugzilla as duplicate of BZ#83342 and add you in CC. I am closing as duplicate here, since Amador's patch also address this report. 

You are welcome to help on tests for http://gerrit.ovirt.org/#/c/5481/ get merged on vdsm tree.

Fell free to re-open this bugzilla if you have any additional question or concern.

Cheers
Douglas

*** This bug has been marked as a duplicate of bug 83342 ***
Comment 4 Douglas Schilling Landgraf 2012-10-03 13:18:08 EDT

*** This bug has been marked as a duplicate of bug 833425 ***

Note You need to log in before you can comment on or make changes to this bug.