Bug 860514 - There are 2 mongodb 2.0 in cartridge list on INT.
There are 2 mongodb 2.0 in cartridge list on INT.
Status: CLOSED WORKSFORME
Product: OpenShift Origin
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Abhishek Gupta
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-25 23:22 EDT by Mengjiao Gao
Modified: 2015-05-14 22:05 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-10 14:48:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The cartridge list page (182.80 KB, image/png)
2012-09-25 23:22 EDT, Mengjiao Gao
no flags Details

  None (edit)
Description Mengjiao Gao 2012-09-25 23:22:58 EDT
Created attachment 617370 [details]
The cartridge list page

Description of problem:
When I tried to add cartridges to applications on INT, I found that there are 2 mongodb 2.0 and no mobgodb2.2 in cartridge list. Since the rockmongo requires mongodb-2.2, so I cannot add rockmongo to apps as well.

This maybe a known issue since mongodb is not upgraded to mongdb-2.2

Version-Release number of selected component (if applicable):
INT(devenv_2221)

How reproducible:
always

Steps to Reproduce:
1.Go to app overview page, click "Add cartridge" button.
2.Check the cartridge list.
3.Add mongodb-2.0, then check the cartridge list again.
  
Actual results:
There are 2 mongodb 2.0 and no mobgodb2.2 in cartridge list page.
After add mongodb-2.0, rockmongo can not be embed as well.

Expected results:
There should only a mongodb-2.2 in the cartridge list page after mongodb is upgraded to 2.2, and after add mongodb-2.2, user should be able to add rockmongo to apps.

Additional info:
Comment 1 Clayton Coleman 2012-09-26 15:27:37 EDT
Talked with operations, not sure what the cause is yet.  INT was in a wierd state because of migrations.
Comment 2 Clayton Coleman 2012-09-27 11:50:07 EDT
https://int.openshift.redhat.com/broker/rest/cartridges.json returns mongodb-2.0 twice, so the UI shows it.  Broker should never return duplicate cartridges.
Comment 3 John Poelstra 2012-10-02 13:21:25 EDT
expect to look at today
Comment 4 John Poelstra 2012-10-04 13:05:08 EDT
will look at today
Comment 5 Abhishek Gupta 2012-10-10 14:43:06 EDT
seems like the latest update to INT fixed this.
Comment 6 Peter Ruan 2012-10-10 14:48:43 EDT
checked out INT on 10/10/12, I don't see it anymore.  closing bug.

Note You need to log in before you can comment on or make changes to this bug.