Bug 860529 - when dkms is installed, building kernel modules for kernels 3.5, 3.6, and 3.7 corrupts corresponding kernel-devel package
when dkms is installed, building kernel modules for kernels 3.5, 3.6, and 3.7...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-26 00:37 EDT by Andre Robatino
Modified: 2013-01-26 12:17 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-26 12:17:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andre Robatino 2012-09-26 00:37:25 EDT
Description of problem:
If dkms is installed, and one is running a kernel >= 3.5, building VirtualBox host or guest modules results in the corresponding System.map file in /usr/src/kernels/* (which belongs to kernel-devel) being deleted. This can be most easily seen by running

ls -l /usr/src/kernels/*/System.map

both before and after. I filed https://www.virtualbox.org/ticket/10847 but the developer is of the opinion that it is not a VirtualBox bug. Since F16 still uses a 3.4.* kernel, it is not affected, but all newer Fedora versions are. I do not know if the problem is triggered by anything other than VirtualBox modules.

Version-Release number of selected component (if applicable):
dkms-2.2.0.3-4.fc18.noarch

How reproducible:
always
Comment 1 Andre Robatino 2012-11-05 16:19:27 EST
I verified that this is not a VirtualBox bug as it is triggered by attempting to build any kind of kernel modules with dkms. See http://lists.us.dell.com/pipermail/dkms-devel/2012-November/001108.html . F16 is now affected as well since it is now using a 3.6 kernel.
Comment 2 Andre Robatino 2013-01-08 09:45:20 EST
This problem may be fixed with the 3.8 kernel. It didn't happen in Rawhide with the 3.8.0-0.rc2.git2.1.fc19.x86_64 kernel (the first 3.8 kernel in Rawhide). If that continues, I'll adjust the Summary to "kernels 3.5, 3.6, and 3.7".
Comment 3 Andre Robatino 2013-01-26 12:17:32 EST
In addition, the problem now seems to be fixed with recent 3.7 kernels in F17 and F18. So this was probably a kernel bug, closing.

Note You need to log in before you can comment on or make changes to this bug.