Bug 860534 - Removing the content of NTP Server 1 will cause an exception and then lead to a blank page
Removing the content of NTP Server 1 will cause an exception and then lead to...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.3
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Fabian Deutsch
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-26 01:07 EDT by Meng Liang
Modified: 2013-02-28 11:40 EST (History)
13 users (show)

See Also:
Fixed In Version: ovirt-node-2.5.0-5.el6
Doc Type: Bug Fix
Doc Text:
Previously, the removal of NTP 1 from the Hypervisor's TUI Network configuration page threw and exception and left the user at a blank page. This behaviour has been corrected, and now NTP server 1 information can be successfully removed from the Network configuration page.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-28 11:40:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen-shot of the error message (43.07 KB, image/png)
2012-09-26 01:08 EDT, Meng Liang
no flags Details

  None (edit)
Description Meng Liang 2012-09-26 01:07:36 EDT
Description of problem:
Removing the content of NTP Server 1 will cause an exception and then lead to a blank page

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.3-20120920.0.rhev31.el6_3

How reproducible:
Always

Steps to Reproduce:
1.clean install rhev-hypervisor6-6.3-20120920.0.rhev31.el6_3
2.Go to network page, delete the content of NTP Server 1 and press <Apply>

  
Actual results:
An error message 'An Exception Has Occurred' display(see attached file) and then value of both NTP Server 1 and 2 are display 'empty' on the network page.

Redo step2 and 3, page will be lead to blank page.

Expected results:
Value of NTP Server could be removed successfully.

Additional info:
Comment 1 Meng Liang 2012-09-26 01:08:44 EDT
Created attachment 617390 [details]
screen-shot of the error message
Comment 3 Meng Liang 2012-09-26 06:05:45 EDT
Change the Actual results to:
An error message 'An Exception Has Occurred' display(see attached file) and then value of both NTP Server 1 and 2 are display 'empty' on the network page.

Reset ntp server and save it, then redo step2, page will be lead to blank page.
Comment 4 Fabian Deutsch 2012-09-27 10:45:10 EDT
The following patch fixes this problem:
http://gerrit.ovirt.org/#/c/8247/

Tested as follows:
1. Install fresh rhevh
2. Apply patch
3. Login and enable a NIC with static IP
4. Remove first NTP server, leave just the second
5. Select <Apply>
= Netwok page reappears and second NTP server appears as first.

Also fixed for DNS.
Comment 7 haiyang,dong 2012-11-02 06:28:39 EDT
Test version:
rhev-hypervisor6-6.4-20121031.0.el6
ovirt-node-2.5.0-8.el6.noarch

Steps:
1. Install  rhevh
2. Login and enable a NIC with static IP
4. Remove first NTP server, leave just the second
5. Select <Apply>
= Netwok page reappears and second NTP server appears as first.

and the same action for DNS.

so this bug has been fixed, change the status into "VERIFIED"
Comment 8 haiyang,dong 2012-12-26 21:49:19 EST
so follow steps of comment 7 to re-test on version
rhev-hypervisor6-6.4-20121212.1.el6, bug was fixed on it.
Comment 11 errata-xmlrpc 2013-02-28 11:40:11 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0556.html

Note You need to log in before you can comment on or make changes to this bug.