Bug 860550 - do not recognize GASP table version 1
do not recognize GASP table version 1
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: fontforge (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-26 02:39 EDT by Pravin Satpute
Modified: 2012-12-20 10:22 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 10:22:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Commit that fixed this (2.22 KB, patch)
2012-09-26 13:07 EDT, Paul Flo Williams
no flags Details | Diff

  None (edit)
Description Pravin Satpute 2012-09-26 02:39:15 EDT
Description of problem:
In LiberatoinSans-Regular.sfd, i did changes and made GASP table version 1 and saved.
But when i again reopen it, it should me GASP table 1

Version-Release number of selected component (if applicable):
fontforge-20110222-7.fc17.x86_64

How reproducible:
everytime

Steps to Reproduce:
1. open LiberationSans-Regular.sfd
2. Element-> Font Information -> Grid Fitting
3. Select Version 1
4. Save and reopen
5. Again it shows Version 0

Actual results:
It does not recognize GASP table version 1

Expected results:
Once save, it should show Version 1 GASP table values

Additional info:
Liberation fonts sfd http://git.fedorahosted.org/cgit/liberation-fonts.git/tree/src/LiberationSans-Regular.sfd
Comment 2 Kevin Fenzi 2012-09-26 11:52:52 EDT
Thanks for filing this upstream. ;)
Comment 3 Paul Flo Williams 2012-09-26 13:07:23 EDT
Created attachment 617672 [details]
Commit that fixed this

The version of the GASP table didn't used to be saved to the SFD at all. This was fixed upstream on 2011-09-18 with commit a0fd436141fa402056ec9f247b3f50cf2b3ecb31, by appending the GASP version to the end of the GASPTable: line of the SFD, and reading it back correctly.

(Sorry, can't patch this today, but feel free if you have time, Kevin.)
Comment 4 Pravin Satpute 2012-09-27 06:08:45 EDT
Thanks Paul for pointing towards patch.

I have done scratch build with it http://koji.fedoraproject.org/koji/taskinfo?taskID=4532402

Still this does not solve problem fully. 
Fontforge is not able to store 4th and 5th column of GASP table
that is Symmetric Smoothing  and Grid Fitting W/ Sym-Smoothing.

Does any development happened on this as well?
Comment 5 Paul Flo Williams 2012-10-01 05:15:11 EDT
I think we need to move F17 to FontForge version 20120731-b. This is already in Rawhide (and, I think, F18). There have been plenty of common crashers fixed since the last release, and this is probably our last chance to update that doesn't bring with it a heap of user interface changes.

As an aside: Pravin, if you wish to file any more bugs upstream (and it's great that you're willing to do so), please use the tracker on GitHub instead of SourceForge, as that is the new upstream. The current list is here:

https://github.com/fontforge/fontforge/issues?state=open
Comment 6 Pravin Satpute 2012-10-01 05:24:52 EDT
Yes sure.
Might be we should update, upstream URL in spec file as well.
Comment 7 Kevin Fenzi 2012-10-01 10:28:28 EDT
I'm ok with a f17 bugfix only update... ;) 

Can you push it out Paul?
Comment 8 Fedora Update System 2012-10-01 16:53:54 EDT
fontforge-20120731b-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/fontforge-20120731b-1.fc17
Comment 9 Fedora Update System 2012-10-02 11:51:28 EDT
Package fontforge-20120731b-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing fontforge-20120731b-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15195/fontforge-20120731b-1.fc17
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2012-12-20 10:22:25 EST
fontforge-20120731b-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.