Bug 860552 - useful input methods like ibus-typing-booster, m17n:t:latn-pre, m17n:t:latn-post should be more easily available
useful input methods like ibus-typing-booster, m17n:t:latn-pre, m17n:t:latn-p...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: control-center (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Control Center Maintainer
Fedora Extras Quality Assurance
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-26 02:44 EDT by Mike FABIAN
Modified: 2013-08-11 11:03 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-11 11:03:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike FABIAN 2012-09-26 02:44:27 EDT
Currently several very useful input methods like ibus-typing-booster,
m17n:t:latn-pre, m17n:t:latn-post are not accessible because they are
not white listed.

Therefore, they cannot be easily selected in the region panel in the
gnome-control-center.

It is possible to make these input methods selectable
in the region panel of gnome-control-center by setting:

   gsettings set org.gnome.desktop.input-sources show-all-sources true

But this obscure setting is very hard to find.

It is not a good situation to hide very useful input methods
so I think something needs to be done about this.
Comment 1 Mike FABIAN 2012-09-26 03:11:26 EDT
On Microsoft Windows, there is the “English International Keyboard”.
It is very similar in behaviour to the m17n:t:latn-pre input method:

http://en.wikipedia.org/wiki/Keyboard_layout#US-International

typing "a becomes ä, typing ~n becomes ñ, ..., i.e. one can type
almost all accented Latin characters easily using a US keyboard.

This is not hidden and easily available in the keyboard settings
in Windows:

http://tlt.its.psu.edu/suggestions/international/keyboards/winkeyvista.html#international

So this seems to be useful enough to have it accessible.

This is extremely useful one one types text in several European
languages.  For example, if one types both French *and* German, it is
much easier to stick to one keyboard layout and type the accented
characters using such an input method then switching between French
and German keyboard layout all the time.

French and German keyboard layouts are very different:

http://en.wikipedia.org/wiki/Keyboard_layout#Austria_and_Germany
http://en.wikipedia.org/wiki/Keyboard_layout#French

one cannot get easily used to such different keyboard layouts, so
typing speed will suffer a lot.

For touch typing, one needs to stick to a layout and get used to
it. Even the difference between the US English and the German keyboard
layout (z and y are swapped, common ASCII characters like []{}\|<>()
are in different positions) is very annoying, switching between US
English and German layout is already quite bad for typing speed.

Switching between very different layouts like between French (azerty)
and German keyboard layout only to be able to type some accented
characters is just terrible. 

In my opinion, if one types accented characters from different
European languages, using something like a latn-pre input method is
far better than switching keyboard layouts.

It is also better than using the Compose mechanism in X11 because there
one has to type

    Multi_key " a

to get ä instead of just

    " a

which means one has to type one key more which is also usually in an
inconvenient position which forces one to move the fingers from the
touch typing base position and back.

So something like the latn-pre and latn-post input methods should be
easily available without setting some obscure key with gsettings.
Comment 2 Rui Matos 2012-09-27 13:11:07 EDT
(In reply to comment #1)
> On Microsoft Windows, there is the “English International Keyboard”.
> It is very similar in behaviour to the m17n:t:latn-pre input method:
> 
> http://en.wikipedia.org/wiki/Keyboard_layout#US-International
> 
> typing "a becomes ä, typing ~n becomes ñ, ..., i.e. one can type
> almost all accented Latin characters easily using a US keyboard.

This is exactly what the "English (US, international with dead keys)" keyboard layout does. And it is visible by default although you can argue that the labeling isn't ideal but we could change that.

> So something like the latn-pre and latn-post input methods should be
> easily available without setting some obscure key with gsettings.

I don't see why you'd need those since they just seem to be duplicating the functionality of the above mentioned keyboard layout.
Comment 3 Mike FABIAN 2013-08-11 11:03:22 EDT
These input methods are not blacklisted anymore, so we
can consider this fixed.

Note You need to log in before you can comment on or make changes to this bug.