Bug 86057 - User-customizable KDE menus impossible
User-customizable KDE menus impossible
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-13 05:23 EST by Peter Åstrand
Modified: 2007-04-18 12:51 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-03 07:59:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Åstrand 2003-03-13 05:23:16 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc1) Gecko/20020417

Description of problem:
In 8.0, it's not possible to customize the KDE menu on a user basis. Eg, I want
different menus for different users. Basically, I want to have a very minimal
menu for some users. I've tried:

1) Using the KDE menu editor, and selecting "Hide" on the system menus. This
creates empty folders in ~/.kde/share/applnk-redhat. But after login, I still
get all menus. This method worked in 7.3. 

2) Creating a new menu hierarchy below /usr/local/kde, and setting
KDEDIRS=/usr/local/kde. Under /usr/local/kde, I've created
share/applnk-redhat/Accessories/.directory with:

[Desktop Entry]
Icon=redhat-accessories.png
Name=Accessories
NoDisplay=true

This doesn't help either; /var/lib/menu will *still* override this. 

3) Using permissions. With 7.3, it was possible to set file permissions on
individual .desktop files, so that these were only displayed for certain users.
This doesn't work with 8.0 either. 



Version-Release number of selected component (if applicable):
3.0.3-14
Comment 1 Ngo Than 2003-04-03 07:59:13 EST
it seems to be fixed in RHL 9 or in kde 3.1.1 which you can download from
ftp.kde.org for RHL 8.0.


Note You need to log in before you can comment on or make changes to this bug.