Bug 8606 - The fix for finding a printer does not work
The fix for finding a printer does not work
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: printtool (Show other bugs)
6.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-01-19 10:28 EST by harwit
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-01-19 10:37:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description harwit 2000-01-19 10:28:29 EST
I have a RedHat 6.1 Deluxe Operating system installed on a separate
harddrive.  The other harddrive uses windows NT 4.0.  I have an HP Laserjet
5MP printer directly attached to my Dell stand-alone workstation Parallel
Port  The printer works flawlessly with the Windows operating system, but
cannot get it to work with the Linux system.  I have used the GXedit tool
to insert the suggested fix in the /etc/conf.modules file, whose contents
now read:

control-panel core mail nsmail
alias parport_lowlevel parport_pc

as directed by your recommended fix. I have configured the PrintTool for a
"Local Printer" and follows:

Names:  lp
Spool Directory: /var/spool/lpd/lp
File limit in Kb: 0
Printer Device: /dev/lp1
Input Filter    Select: *auto*-PostScript

(I found no other printer name that seemed to better match the HP LaserJet
5MP)

When I try to send a test message, either with the ASCII or the Postscript
Test page, I get the following error message:

"Error printing tyest page to queu lp"

"Error reason: lpr: connect: Connection refused
jobs queud, but cannot start daemon."

CAN YOU PLEASE ADVISE ME WHAT TO DO?  I'VE PLAYED AROUND WITH THIS FOR
HOURS, NOW, TRYING DIFFERENT PRINTER DEVICE NAMES, AS SUGGESTED BY YOUR
HELP PROGRAM, BUT NOTHING WORKS.  I AM UNABLE TO USE THE PRINTER! PLEASE
ADVISE.  THIS IS A SERIOUS NUISANCE.
Comment 1 Bernhard Rosenkraenzer 2000-01-19 10:37:59 EST
Looks like your lpd isn't running.
Make sure you're using the latest lpr package from errata (0.50, I think) and
run /etc/rc.d/init.d/lpd stop ; /etc/rc.d/init.d/lpd start

Note You need to log in before you can comment on or make changes to this bug.