Bug 860627 - irqbalance is not being daemonize
irqbalance is not being daemonize
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: irqbalance (Show other bugs)
6.4
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Petr Holasek
Evan McNabb
:
Depends On:
Blocks: 841211
  Show dependency treegraph
 
Reported: 2012-09-26 06:41 EDT by Michal Kovarik
Modified: 2016-10-04 00:08 EDT (History)
3 users (show)

See Also:
Fixed In Version: irqbalance-1.0.4-2.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 04:49:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
remove --foreground from init script (389 bytes, patch)
2012-09-26 06:41 EDT, Michal Kovarik
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0367 normal SHIPPED_LIVE irqbalance bug fix and enhancement update 2013-02-20 15:52:47 EST

  None (edit)
Description Michal Kovarik 2012-09-26 06:41:58 EDT
Created attachment 617496 [details]
remove --foreground from init script

Description of problem:
After successful installation system freeze on "Starting irqbalance:".

Version-Release number of selected component (if applicable):
RHEL6.4-20120925.n.3
irqbalance-1.0.4-1.el6

How reproducible:
Always

Steps to Reproduce:
1. service start irqbalance
  
Actual results:
freezing on irqbalance start

Expected results:
successful deamonize

Additional info:
Comment 7 Evan McNabb 2012-12-06 16:31:32 EST
Confirmed option is removed in irqbalance-1.0.4-3.el6 and it starts correctly:

# rpm -q irqbalance
irqbalance-1.0.4-1.el6.x86_64
# grep foreground /etc/init.d/irqbalance 
        daemon irqbalance --foreground $IRQBALANCE_ARGS $ONESHOT
# service irqbalance start
Starting irqbalance: 
... hang ...

# rpm -Uvh irqbalance-1.0.4-3.el6.x86_64.rpm 
warning: irqbalance-1.0.4-3.el6.x86_64.rpm: Header V3 RSA/SHA256 Signature, key ID f21541eb: NOKEY
Preparing...                ########################################### [100%]
   1:irqbalance             ########################################### [100%]
# grep foreground /etc/init.d/irqbalance 
# service irqbalance start
Starting irqbalance:                                       [  OK  ]
#
Comment 9 errata-xmlrpc 2013-02-21 04:49:29 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0367.html

Note You need to log in before you can comment on or make changes to this bug.