This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 860634 - firstboot sets DISPLAY so no need to use "WM --display"
firstboot sets DISPLAY so no need to use "WM --display"
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vratislav Podzimek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-26 07:24 EDT by Jens Petersen
Modified: 2013-10-14 06:46 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-14 06:46:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
firstboot-frontend-wm-display.patch (644 bytes, patch)
2012-09-26 07:24 EDT, Jens Petersen
no flags Details | Diff

  None (edit)
Description Jens Petersen 2012-09-26 07:24:06 EDT
Created attachment 617523 [details]
firstboot-frontend-wm-display.patch

Description of problem:
Firstboot fails to start openbox and will fail to start other
(yet unsupported) WM's that do not support the --display option either.

It would be better if firstboot set DISPLAY=:9 for the WM process
instead of using --display=:9 which is not supported by many
window managers.  Otherwise it would be better not to start
a window manager since "openbox --display" crashes immediately anyway.
And in fact for most users firstboot works well enough without
a windowmanager.

In fact since the DISPLAY envvar is already set in frontend.py
--display is redundant and can be dropped.  The attached patch
does that.

Version-Release number of selected component (if applicable):
18.4

How reproducible:
100%

Steps to Reproduce:
1. install LXDE
2. boot to firstboot
3. Go to a VC and check openbox process status.
4. Click on user account buttons to popup windows.
  
Actual results:
3. openbox crashed at startup [defunct] due to unsupported --display option.
4. windows not decorated

Expected results:
3. window managers that don't support --display not to crash
4. popup windows to be handled by WM.


Additional info:
I tested metacity, xfwm4, openbox, and xmonad with the --display option dropped and they all work find in firstboot.  (I can test kwin later.)
Comment 1 Fedora Admin XMLRPC Client 2013-10-14 05:19:00 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 2 Vratislav Podzimek 2013-10-14 06:46:58 EDT
The firstboot utility is deprecated and no longer developed in Fedora 19 and newer releases. It was replaced by the initial-setup utility with a completely different codebase. If you still have any similar problems with Fedora 19 or later, please file a new bug against initial-setup or gnome-initial-setup if you did a GNOME install.

Note You need to log in before you can comment on or make changes to this bug.