Bug 860704 - HA backups continuously disconnect / re-sync after attempting to replicate a deleted queue
HA backups continuously disconnect / re-sync after attempting to replicate a ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
Development
Unspecified Unspecified
high Severity high
: 2.3
: ---
Assigned To: Alan Conway
MRG Quality Engineering
: OtherQA
: 860412 (view as bug list)
Depends On:
Blocks: 698367
  Show dependency treegraph
 
Reported: 2012-09-26 10:12 EDT by Jason Dillaman
Modified: 2013-03-19 12:38 EDT (History)
6 users (show)

See Also:
Fixed In Version: qpid-cpp-0.18-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-19 12:38:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Quick patch to work-around the discovered issues (6.27 KB, patch)
2012-09-26 10:25 EDT, Jason Dillaman
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Apache JIRA QPID-4285 None None None 2012-09-26 10:12:40 EDT

  None (edit)
Description Jason Dillaman 2012-09-26 10:12:40 EDT
See https://issues.apache.org/jira/browse/QPID-4285
Comment 1 Jason Dillaman 2012-09-26 10:25:28 EDT
Created attachment 617569 [details]
Quick patch to work-around the discovered issues
Comment 2 Alan Conway 2012-10-02 14:46:53 EDT
Taken from trunk r1393089

Bug-860704 - QPID-4285: HA backups continuously disconnect / re-sync after attempting to replicate a deleted queue. (Based on patch Jason Dillama)
    
    This does not directly tackle the origin of the problem but extends Jasons's patch since
    it addresses something we had to fix anyway: "leaking" queues and exchanges. It does 2 things.
    
    1. enabled hideDeletedError on all subscription objects used by HA
    This suppress the troublesome exception with a harmless no-op
    
    2. Delete queues/exchanges missing from responses (based on Jasons patch)
    Fix the "leak" of queues and exchanges possible when an object replicated
    to a backup is deleted from the newn primary before the backup connects.
Comment 3 Alan Conway 2012-10-02 17:53:35 EDT
Committed to release repo http://mrg1.lab.bos.redhat.com/cgit/qpid.git/commit/?h=0.18-mrg&id=017c5e13f9bdaf6e516f7b1cd86624ec51c438b0

and on trunk:
 ------------------------------------------------------------------------
r1393201 | aconway | 2012-10-02 17:46:50 -0400 (Tue, 02 Oct 2012) | 9 lines

QPID-4285: HA backups continuously disconnect / re-sync after attempting to replicate a deleted queue

Fixes queues getting into a partially deleted state: previously when a broker was
promoted, it did not clean up it's QueueReplicators. The QueueReplicators keep a
shared_ptr to the Queue so this kept Queues in memory after they were destroyed. It also
kept them in QMF, since the management object is unregistered in the destructor.

This patch cleans up properly on promotion.

------------------------------------------------------------------------
Comment 5 Mike Cressman 2012-10-17 18:10:24 EDT
*** Bug 860412 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.