Bug 860705 - Activation key delete displays error
Activation key delete displays error
Status: CLOSED DUPLICATE of bug 858802
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
6.0.1
x86_64 Linux
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Adam Price
Og Maciel
: Triaged
Depends On: 840792
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-26 10:12 EDT by Jordan OMara
Modified: 2014-11-09 17:56 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 840792
Environment:
Last Closed: 2012-10-11 16:17:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot (63.66 KB, image/png)
2012-10-09 10:39 EDT, Og Maciel
no flags Details

  None (edit)
Description Jordan OMara 2012-09-26 10:12:46 EDT
+++ This bug was initially created as a clone of Bug #840792 +++

Created attachment 598587 [details]
Activation key delete

Description of problem:
A system is registered using the activation key. deleting 
that activation key displays unknown error
The error should be user friendly stating the reason
for not being deleted
Version-Release number of selected component (if applicable):
[root@nec-em9 ~]# rpm -qa | grep katello
katello-certs-tools-1.1.6-1.fc16.noarch
katello-configure-0.2.30-1.fc16.noarch
katello-headpin-all-0.2.24-1.fc16.noarch
katello-selinux-0.2.6-1.fc16.noarch
katello-cli-common-0.2.43-1.fc16.noarch
katello-glue-candlepin-0.2.45-1.fc16.noarch
katello-cli-headpin-0.1.19-1.fc16.noarch
katello-headpin-0.2.24-1.fc16.noarch
katello-common-0.2.45-1.fc16.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch


How reproducible:
yum install -y katello-headpin-all
katello-configure --deployment=sam

Steps to Reproduce:
1.Login to SAM WEB UI
2.Navigate to Content Tab 
3.select Activation key
4.Create a activation key
5.register a system using that activation key 
6.Remove that key

  
Actual results:
Activation key cannot be deleted
The error is not user friendly

Expected results:
Appropriate error should be displayed
to specify the reason for not deleting the key

Additional info:
screen shot attached
Comment 1 Adam Price 2012-10-05 13:14:02 EDT
asking for more info in 840792 from tazim. cannot currently reproduce.
Comment 2 Adam Price 2012-10-08 10:16:08 EDT
in an email sent from Tazim:

Verified with the packages:
   
   [root@dell-pesc1425-01 ~]# rpm -qa | grep katello-cli
   katello-cli-common-1.1.9-1.git.6.8db32c1.el6.noarch
   katello-cli-1.1.9-1.git.6.8db32c1.el6.noarch
  
   The activation key can be deleted successfully with appropriate error.
  
   Please, update the bug status accordingly to ON_QA so that I can verify and close it.
Comment 3 Og Maciel 2012-10-09 10:39:27 EDT
Created attachment 624122 [details]
Screenshot

* Create an activation key with access to subscriptions
* Register and subscribe a client using activation key
* Delete the activation key through the web ui
Comment 4 Og Maciel 2012-10-09 10:43:41 EDT
To be clear, the issue is to wordsmith the following error message:

  Cannot delete record because of dependent system_activation_keys   (ActiveRecord::DeleteRestrictionError) Click here for more details.

to be a bit clearer as to why the key cannot be deleted
Comment 5 Og Maciel 2012-10-09 11:00:34 EDT
Fails QA:

* candlepin-0.7.8.1-1.el6cf.noarch
* candlepin-selinux-0.7.8.1-1.el6cf.noarch
* candlepin-tomcat6-0.7.8.1-1.el6cf.noarch
* katello-1.1.12-14.el6cf.noarch
* katello-all-1.1.12-14.el6cf.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.1.8-1.el6cf.noarch
* katello-cli-1.1.8-7.el6cf.noarch
* katello-cli-common-1.1.8-7.el6cf.noarch
* katello-common-1.1.12-14.el6cf.noarch
* katello-configure-1.1.9-7.el6cf.noarch
* katello-glue-candlepin-1.1.12-14.el6cf.noarch
* katello-glue-pulp-1.1.12-14.el6cf.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-1.1.1-1.el6cf.noarch
* pulp-1.1.12-1.el6cf.noarch
* pulp-common-1.1.12-1.el6cf.noarch
* pulp-selinux-server-1.1.12-1.el6cf.noarch
Comment 6 Og Maciel 2012-10-10 09:51:17 EDT
Seems that we need katello-cli-common-1.1.10-1h.el6_3.noarch to verify this.
Comment 7 Adam Price 2012-10-11 16:17:30 EDT

*** This bug has been marked as a duplicate of bug 858802 ***
Comment 8 Mike McCune 2013-08-16 14:23:38 EDT
getting rid of 6.0.0 version since that doesn't exist

Note You need to log in before you can comment on or make changes to this bug.