Bug 860722 - CDN listing fetcher does not correctly handle 300 redirect http code
CDN listing fetcher does not correctly handle 300 redirect http code
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: API (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity low (vote)
: Unspecified
: --
Assigned To: Katello Bug Bin
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-26 10:53 EDT by Lukas Zapletal
Modified: 2014-03-18 13:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-18 13:37:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lukas Zapletal 2012-09-26 10:53:36 EDT
Our CDN listing fetcher downloader does not properly handle redirects. I am not sure if CDN has any of these, but it would fail.

If we are going to fix it, we need to fix two bits:

src/lib/resources/cdn.rb method get

and

katello-utils/bin/katello-disconnected method get
Comment 2 Miroslav Suchý 2012-09-26 11:37:52 EDT
Is not just about 300.

We parse only 200, 404 and 403. But there are other in RFC. Besice 30x there is 100, which means I'm working on it, hold on and ignore this response.
OpenURI may handle this for us.
Comment 4 Mike McCune 2014-03-18 13:37:50 EDT
This bug was closed because of a lack of activity.  If you feel this bug should be reconsidered for attention please feel free to re-open the bug with a comment stating why it should be reconsidered.

Note You need to log in before you can comment on or make changes to this bug.