Bug 860724 - SELinux is preventing /usr/sbin/php-fpm from 'name_connect' accesses on the tcp_socket .
SELinux is preventing /usr/sbin/php-fpm from 'name_connect' accesses on the t...
Status: CLOSED DUPLICATE of bug 860746
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:830371b77d5be654f5607903f2c...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-26 10:58 EDT by Jonathan VK
Modified: 2012-09-26 14:02 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-26 14:02:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: type (9 bytes, text/plain)
2012-09-26 10:58 EDT, Jonathan VK
no flags Details
File: hashmarkername (14 bytes, text/plain)
2012-09-26 10:58 EDT, Jonathan VK
no flags Details

  None (edit)
Description Jonathan VK 2012-09-26 10:58:33 EDT
Additional info:
libreport version: 2.0.13
kernel:         3.6.0-0.rc6.git0.2.fc18.x86_64

description:
:SELinux is preventing /usr/sbin/php-fpm from 'name_connect' accesses on the tcp_socket .
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that php-fpm should be allowed name_connect access on the  tcp_socket by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep php-fpm /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:phpfpm_t:s0
:Target Context                system_u:object_r:mysqld_port_t:s0
:Target Objects                 [ tcp_socket ]
:Source                        php-fpm
:Source Path                   /usr/sbin/php-fpm
:Port                          3306
:Host                          (removed)
:Source RPM Packages           php-fpm-5.4.7-5.fc18.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.11.1-21.fc18.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.6.0-0.rc6.git0.2.fc18.x86_64 #1
:                              SMP Mon Sep 17 17:29:08 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    2012-09-26 10:56:20 EDT
:Last Seen                     2012-09-26 10:56:20 EDT
:Local ID                      d5cbe08f-caa4-416e-93a3-f9c639c5d99f
:
:Raw Audit Messages
:type=AVC msg=audit(1348671380.0:1003): avc:  denied  { name_connect } for  pid=16784 comm="php-fpm" dest=3306 scontext=system_u:system_r:phpfpm_t:s0 tcontext=system_u:object_r:mysqld_port_t:s0 tclass=tcp_socket
:
:
:type=SYSCALL msg=audit(1348671380.0:1003): arch=x86_64 syscall=connect success=no exit=EINPROGRESS a0=4 a1=26cab80 a2=10 a3=40 items=0 ppid=16780 pid=16784 auid=4294967295 uid=48 gid=48 euid=48 suid=48 fsuid=48 egid=48 sgid=48 fsgid=48 tty=(none) ses=4294967295 comm=php-fpm exe=/usr/sbin/php-fpm subj=system_u:system_r:phpfpm_t:s0 key=(null)
:
:Hash: php-fpm,phpfpm_t,mysqld_port_t,tcp_socket,name_connect
:
:audit2allow
:
:#============= phpfpm_t ==============
:allow phpfpm_t mysqld_port_t:tcp_socket name_connect;
:
:audit2allow -R
:
:#============= phpfpm_t ==============
:allow phpfpm_t mysqld_port_t:tcp_socket name_connect;
:
Comment 1 Jonathan VK 2012-09-26 10:58:40 EDT
Created attachment 617595 [details]
File: type
Comment 2 Jonathan VK 2012-09-26 10:58:42 EDT
Created attachment 617596 [details]
File: hashmarkername
Comment 3 Miroslav Grepl 2012-09-26 14:02:53 EDT

*** This bug has been marked as a duplicate of bug 860746 ***

Note You need to log in before you can comment on or make changes to this bug.