Bug 860747 - libparted really hates sun label VTOC (SMI)
libparted really hates sun label VTOC (SMI)
Status: CLOSED DUPLICATE of bug 851194
Product: Fedora
Classification: Fedora
Component: parted (Show other bugs)
17
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-26 11:43 EDT by Bryce
Modified: 2012-11-01 22:07 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-01 22:07:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of libparted probe on anaconda's behalf (238.02 KB, image/jpeg)
2012-09-26 11:43 EDT, Bryce
no flags Details
512K VTOC header of same drive (512 bytes, application/octet-stream)
2012-09-26 11:52 EDT, Bryce
no flags Details

  None (edit)
Description Bryce 2012-09-26 11:43:50 EDT
Created attachment 617616 [details]
Screenshot of libparted probe on anaconda's behalf

Description of problem:
libparted has a really horrible time with sun formatted drives
If you try and use a sun label formatted drive with anaconda libparted falls apart but I've not determined if this is down to the kernel or to libparted.


Version-Release number of selected component (if applicable):
fc17 ISO version 3.0.3/4?

How reproducible:
Take any sun label disk (NOT ONE MADE BY PARTED!)
try and use it as the install drive

  
Actual results:
(see screen shot attachment)

Expected results:
libparted to feed back the device specifics and later some moan about the format from anaconda 

Additional info:
I'll provide the 512K header of the drive as formatted by solaris in another attachment
Comment 1 Bryce 2012-09-26 11:52:54 EDT
Created attachment 617621 [details]
512K VTOC header of same drive

This is a corsair SSD (120Gb)

Sun formatting sets the geometry as follows
ATA-Corsair Force 3-3 cyl 65533 alt 2 hd 16 sec 223

[root@blackknight ~]# dd if=/dev/zero of=/dev/sdk bs=512 count=1
[root@blackknight ~]# parted /dev/sdk mklabel sun
[root@blackknight ~]# parted /dev/sdk print
Model: ATA Corsair Force 3 (scsi)
Disk /dev/sdk: 120GB
Sector size (logical/physical): 512B/512B
Partition Table: sun

Number  Start  End  Size  File system  Flags
[root@blackknight ~]# python
Python 2.7 (r27:82500, Sep 16 2010, 18:02:00) 
[GCC 4.5.1 20100907 (Red Hat 4.5.1-3)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import parted
>>> sd = parted.Device(path="/dev/sdk")
>>> disk = parted.Disk(device=sd)
>>> print sd.biosGeometry
(14593, 255, 63)

however, by doing that, the disk geometry alignment becomes nonsensical
>>> print sd.optimumAlignment.intersect(disk.partitionAlignment).grainSize
32901120
Comment 2 Bryce 2012-11-01 22:07:17 EDT
Dupe of Bug 851194

*** This bug has been marked as a duplicate of bug 851194 ***

Note You need to log in before you can comment on or make changes to this bug.