Bug 860751 - %postun scriptlet fails for aeolus-conductor-daemons
%postun scriptlet fails for aeolus-conductor-daemons
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity high
: beta3
: ---
Assigned To: John Eckersberg
Rehana
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-26 12:04 EDT by John Eckersberg
Modified: 2012-12-04 10:21 EST (History)
6 users (show)

See Also:
Fixed In Version: aeolus-conductor-0.13.15-1.el6cf
Doc Type: Bug Fix
Doc Text:
When upgrading from CloudForms 1.1 on Red Hat Enterprise Linux 6, the script to upgrade the aeolus-conductor-daemons attempted to invoke the 'systemctl' command, which was not present on these systems. This update changes to the 'sysvinit condrestart' command instead and the aeolus-conductor-daemons now update as expected.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 10:21:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Eckersberg 2012-09-26 12:04:53 EDT
Description of problem:
%postun scriptlet fails for aeolus-conductor-daemons

Version-Release number of selected component (if applicable):
aeolus-conductor-daemons-0.13.14-1.el6cf.noarch.rpm

How reproducible:
Always

Steps to Reproduce:
1. Upgrade aeolus-conductor-daemons
  
Actual results:
Cleanup    : aeolus-conductor-daemons-0.13.6-1.el6cf.noarch                                             9/14
Non-fatal POSTUN scriptlet failure in rpm package aeolus-conductor-daemons
warning: %postun(aeolus-conductor-daemons-0.13.6-1.el6cf.noarch) scriptlet failed, exit status 127

Expected results:
No scriptlet failures
Comment 1 John Eckersberg 2012-09-26 12:09:36 EDT
%postun gets installed as included in the *old* spec of the package.  Note in the output above that the version in the error is 0.13.6 which just happens to be the old version I had installed.

The version in 1.0 does not have a %postun section, so when upgrading from 1.0 to latest puddle, there will be no error.  However, upgrading from one 1.1 version to the next will exhibit this behavior.

More importantly, if left as is, this error will break upgrade from 1.1 to 1.2/2.0/whatever-is-next.
Comment 2 John Eckersberg 2012-09-26 15:52:22 EDT
https://github.com/aeolusproject/conductor/pull/78
Comment 3 John Eckersberg 2012-09-26 15:53:31 EDT
In summary, the scriptlet tries to invoke systemctl on el6, which isn't present so it blows up.  The pull request above changes it to do a sysvinit condrestart on el6 instead.
Comment 5 Steve Linabery 2012-10-01 17:24:49 EDT
43c6345b883bdafd5abcebecc80ace31efc4bbac on 1.1 also addresses TPS failed downgrade.
Comment 6 Shveta 2012-10-11 13:57:14 EDT
[root@vmware-esx-01-g1 ~]# wget download.devel.redhat.com/brewroot/packages/aeolus-conductor/0.13.18/1.el6cf/noarch/aeolus-conductor-daemons-0.13.18-1.el6cf.noarch.rpm
--2012-10-11 13:48:21--  http://download.devel.redhat.com/brewroot/packages/aeolus-conductor/0.13.18/1.el6cf/noarch/aeolus-conductor-daemons-0.13.18-1.el6cf.noarch.rpm
Resolving download.devel.redhat.com... 10.10.36.199
Connecting to download.devel.redhat.com|10.10.36.199|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 29092 (28K) [application/x-rpm]
Saving to: “aeolus-conductor-daemons-0.13.18-1.el6cf.noarch.rpm”

100%[===================================================================================================================================================================================================>] 29,092      15.3K/s   in 1.9s    

2012-10-11 13:48:24 (15.3 KB/s) - “aeolus-conductor-daemons-0.13.18-1.el6cf.noarch.rpm” saved [29092/29092]

[root@vmware-esx-01-g1 ~]# ll
total 96
-rw-r--r--. 1 root root 29092 Oct  9 10:36 aeolus-conductor-daemons-0.13.18-1.el6cf.noarch.rpm
-rw-------. 1 root root 10750 Oct  9 23:34 anaconda-ks.cfg
-rwxrwxrwx. 1 root root  1437 Oct 10 14:15 check_kvm.sh
-rw-r--r--. 1 root root 27292 Oct  9 23:34 install.log
-rw-r--r--. 1 root root  7569 Oct  9 23:33 install.log.syslog
-rw-r--r--. 1 root root     4 Oct  9 23:34 NETBOOT_METHOD.TXT
-rw-r--r--. 1 root root     7 Oct  9 23:34 RECIPE.TXT
[root@vmware-esx-01-g1 ~]#  rpm -U --force aeolus-conductor-daemons-0.13.18-1.el6cf.noarch.rpm
[root@vmware-esx-01-g1 ~]# rpm -qa|grep aeolus-conductor-daemons
aeolus-conductor-daemons-0.13.18-1.el6cf.noarch




====================================================

rpm -qa|grep aeolus
aeolus-conductor-0.13.18-1.el6cf.noarch
aeolus-configure-2.8.9-1.el6cf.noarch
aeolus-all-0.13.18-1.el6cf.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-conductor-daemons-0.13.18-1.el6cf.noarch
aeolus-conductor-doc-0.13.18-1.el6cf.noarch
rubygem-aeolus-cli-0.7.4-1.el6cf.noarch
Comment 8 errata-xmlrpc 2012-12-04 10:21:51 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.