This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 860767 - cxgb3 on vlan-enabled network config does not pass TCP traffic
cxgb3 on vlan-enabled network config does not pass TCP traffic
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.8
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Doug Ledford
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-26 12:40 EDT by Jay Fenlason
Modified: 2014-08-31 19:31 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-20 10:36:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Fenlason 2012-09-26 12:40:51 EDT
Description of problem:
If you configure a cxgb3 adapter to use a specific vlan, tcp traffic on that interface is dropped/blocked/othewise not sent to userspace.

Version-Release number of selected component (if applicable):
kernel-2.6.18-308.12.1.el5

How reproducible:
Always

Steps to Reproduce:
1.Configure two machines with cxgb3 interfaces to talk over a vlan
2.ping one machine from the other one, confirm that icmp packets are not blocked
3.attempt to ssh from one machine to the other, observe that no connection happens
  
Actual results:
Packets lost

Expected results:
packets passed

Additional info:
We've seen this on multiple network configurations.
Comment 1 Jay Fenlason 2012-10-02 11:42:34 EDT
This only appears to happen when the base interface (the one with no vlan configuration) is not given an IP address and brought up.  Simply doing an "ifconfig cxgb3 0.0.0.0 up" causes the interface to start correctly passing traffic.  I'm investigating what piece of init code isn't being run.
Comment 2 Doug Ledford 2013-02-20 10:36:02 EST
The base interface must be up before the vlan interfaces are expected to work.  You've confirmed that it works once the interface comes up, so this really is a configuration issue, not a bug.

Note You need to log in before you can comment on or make changes to this bug.