Bug 860786 - daemon-reload complains Argument 0 is specified to be of type "string", but is actually of type "invalid"
daemon-reload complains Argument 0 is specified to be of type "string", but i...
Status: CLOSED DUPLICATE of bug 859614
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-26 13:22 EDT by Jason Montleon
Modified: 2012-09-27 12:41 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-27 12:41:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Montleon 2012-09-26 13:22:37 EDT
Description of problem:
systemctl daemon-reload fails with error:
Failed to issue method call: Argument 0 is specified to be of type "string", but is actually of type "invalid"

Version-Release number of selected component (if applicable):
fedora-release-18-0.8.noarch
systemd-191-2.fc18.x86_64
No additional updates available.

How reproducible:
Always, happens every time I run the command, even after a reboot.

Steps to Reproduce:
1. Install Fedora 18
2. Install nrpe, and fix the systemd unit file (separate bug - path to binary is incorrectly /bin instead of /sbin on hte ExecStart line)
3. Issue systemctl daemon-reload
  
Actual results:
Get error: Failed to issue method call: Argument 0 is specified to be of type "string", but is actually of type "invalid"

Expected results:
reloads everything normally.

Additional info:
Unfortunately I don't know how to track down if this is one of the other unit files is causing a problem or something else entirely, but I will be happy to run whatever is needed to get to the bottom of it. I uninstalled nrpe and verified it wasn't this specific service/file that was causing the reload problem.
Comment 1 Lennart Poettering 2012-09-27 12:41:15 EDT

*** This bug has been marked as a duplicate of bug 859614 ***

Note You need to log in before you can comment on or make changes to this bug.