Bug 860804 - brasero side panel crash
brasero side panel crash
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: brasero (Show other bugs)
7.0
x86_64 Linux
unspecified Severity high
: rc
: ---
Assigned To: Tomáš Bžatek
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-26 14:33 EDT by Mark Gordon
Modified: 2015-03-03 18:05 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-17 07:13:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Gordon 2012-09-26 14:33:49 EDT
Description of problem:
Creating a file in a directory that brasero is viewing can cause brasero to crash.

Version-Release number of selected component (if applicable):
brasero-3.4.1-1.el7.x86_64
(also seeing this problem with brasero-3.4.1-1.fc17.x86_64)

How reproducible:
100%

Steps to Reproduce:
1. cd; touch foo
2. In brasero, create a new data project.  
3. Make sure the side panel is visible (F7 to toggle).
4. Browse to the directory in which foo was created.
5. Add foo to the project.
6. Remove foo from the project.
7. rm foo; touch foo
  
Actual results:
Gtk:ERROR:gtkrbtree.c:465:_gtk_rbtree_insert_after: assertion failed: (_gtk_rbtree_is_nil (tree->root))
Aborted (core dumped)

Expected results:
foo reappears in the side panel

Additional info:
Works with directories as well, i.e. you can use mkdir and rmdir instead of touch and rm to reproduce the crash.
Comment 1 Tomáš Bžatek 2012-12-14 12:08:15 EST
I cannot reproduce this with brasero-3.6.1-1.fc18.i686, file changes in the current directory are reflected in the UI just fine, no warnings on console.

Any chance you can grab a stacktrace for analysis?
Comment 2 Mark Gordon 2012-12-14 19:19:07 EST
I'm unable to reproduce this in more recent RHEL 7 with brasero-3.6.1-1.el7
Comment 3 Tomáš Bžatek 2012-12-17 07:13:07 EST
OK, closing for now, feel free to reopen when you see this again.

Note You need to log in before you can comment on or make changes to this bug.