This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 860807 - scheduled operation with params but no values set doesn't render
scheduled operation with params but no values set doesn't render
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
4.5
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: RHQ 4.6
Assigned To: John Mazzitelli
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-26 14:37 EDT by John Mazzitelli
Modified: 2013-09-04 03:27 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-04 03:27:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Mazzitelli 2012-09-26 14:37:07 EDT
Schedule an operation to execute in the future. Go to the scheduled subtab, and click the link of the scheduled operation. You get an ugly red error and the rendering isn't correct.

Problem is this:

                if (isNewRecord()) {
                    ConfigurationTemplate defaultTemplate = parametersDefinition.getDefaultTemplate();
                    this.operationParameters = (defaultTemplate != null) ? defaultTemplate.createConfiguration()
                        : new Configuration();
                } else {

                }

I have no idea why an empty else clause is here. This should be the body of the else clause:

  this.operationParameters = new Configuration();

I don't know if this is related to bug 852014 but hey, you never know.
Comment 1 John Mazzitelli 2012-09-26 14:37:42 EDT
fyi: that code snippet is found in: 

org.rhq.enterprise.gui.coregui.client.inventory.common.detail.operation.schedule.AbstractOperationScheduleDetailsView.refreshOperationParametersItem()
Comment 2 John Mazzitelli 2012-09-26 14:41:18 EDT
git commit to master 83d01ea
Comment 3 John Mazzitelli 2012-09-26 14:58:16 EDT
uh... this is weird. On JON 3.1.1, this actually works ok. The view shows "This operation does not take any parameters." But yet when built on AS7 branch after merged with master, the bug shows up.
Comment 4 John Mazzitelli 2012-09-26 15:26:36 EDT
the description of this bug wasn't fully accurate. You need to select an operation that DOES have an operation, but the values are all unset and you never set them.

for example, the RHQ Agent operation "Get Current Date/Time".
Comment 5 John Mazzitelli 2012-09-26 16:11:29 EDT
I'm putting this back on ON_QA for QA just to test this again. Because its possible master was broken again. I committed what I think is a fix - it works for me now.
Comment 6 Armine Hovsepyan 2013-05-30 05:28:22 EDT
verified w/wo setting params
build:ff37cd9
Comment 7 Heiko W. Rupp 2013-09-04 03:27:56 EDT
Done in an old release, closing now.

Note You need to log in before you can comment on or make changes to this bug.